如何在Ubuntu 18.4 Linux操作系统上安装odoo 13?

ubuntu安装odoo
ubuntu安装odoo

Linux/Ubuntu操作系统下安装和熟悉ODOO 13这套软件系统只需半个小时以内,很简单的几个步骤就能搞定。首先得在服务器( Linux/Ubuntu操作系统 )上面安装好ODOO 13软件系统和数据库。

当然也可以有其他安装方法,就是安装web server (普通的PC Server 即可),然后就可以使用web 浏览器访问。或是在每台用户电脑上都安装客户端软件。

参考官方文档:https://www.odoo.com/documentation/13.0/setup/install.html

注意:下面所有运行指令均需使用root权限。

第一步:安装 PostgreSQL ,运行代码如下:

apt-get install postgresql -y

第二步:安装 wkhtmltopdf

这个主要用于odoo erp中pdf生成,我暂时没有装。如需安装可参考上面官方链接!

第三步:依次执行下面的三个运行指令:

wget -O - https://nightly.odoo.com/odoo.key | apt-key add -
echo "deb http://nightly.odoo.com/13.0/nightly/deb/ ./" >> /etc/apt/sources.list.d/odoo.list
apt-get update && apt-get install odoo

第四步:运行一个更新指令:

apt-get upgrade

官网上就这几个步骤,但是你在浏览器输入:localhost:8069,发现无法访问。

先解决几个问题:

1、第四步运行指令会提示:有几个软件包无法下载,要不运行 apt-get update 或者加上 –fix-missing 的选项再试试?

答:请在终端输入命令apt-get upgrade fix-missing,再次进行修复性安装更新。

2、安装和配置PostgreSQL?

答:参考如何在Ubuntu 15.04上安装Odoo ERP软件(推荐)这篇文章的第三步。

3、如何检查以下odoo是否安装好?

答:其实看一下系统有没有开启8069端口就可以,运行命令netstat -plntu查看!下图就是没有开启8069端口的截图,也说明odoo 13虽然执行官网给的的指令,但是依然没有安装成功!

查看Ubuntu端口开放情况
查看Ubuntu端口开放情况

4、执行完上面的指令,依然没有安装成功odoo 13怎么办?

答:重新运行安装指令!apt-get update && apt-get install odoo

再通过netstat -plntu查看奇迹出现了,如下图:是不是找到了8069端口!

查看Ubuntu端口开放情况
查看Ubuntu端口开放情况

再去浏览器查看:localhost:8069 ,你会看到下图:

odoo在ubuntu安装成功
odoo在ubuntu安装成功
odoo应用界面
odoo应用界面

留个问题,请认真思考如何在Ubuntu 15.04上安装Odoo ERP软件(推荐)这篇文章第二步是否必要?他和第三步配置postgresql有什么关联?

——louis

收工!

安装运行指令奉上:

root@louis-PC:~# apt-get install postgresql -y
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
下列软件包是自动安装的并且现在不需要了:
  binutils-common:i386 binutils-i686-linux-gnu gcc-7-base:i386 libasan4:i386
  libbinutils:i386 libcc1-0:i386 libcilkrts5:i386 libgcc-7-dev:i386
  libgomp1:i386 libisl19:i386 libitm1:i386 libllvm7 libmpc3:i386 libmpfr6:i386
  libmpx2:i386 libquadmath0:i386 libubsan0:i386
使用'apt autoremove'来卸载它(它们)。
将会同时安装下列软件:
  libpq5 postgresql-10 postgresql-client-10 postgresql-client-common
  postgresql-common sysstat
建议安装:
  postgresql-doc locales-all postgresql-doc-10 libjson-perl isag
下列【新】软件包将被安装:
  libpq5 postgresql postgresql-10 postgresql-client-10
  postgresql-client-common postgresql-common sysstat
升级了 0 个软件包,新安装了 7 个软件包,要卸载 0 个软件包,有 52 个软件包未被升级。
需要下载 5,287 kB 的归档。
解压缩后会消耗 20.8 MB 的额外空间。
获取:1 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libpq5 amd64 10.10-0ubuntu0.18.04.1 [108 kB]
获取:2 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 postgresql-client-common all 190 [29.5 kB]
获取:3 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 postgresql-client-10 amd64 10.10-0ubuntu0.18.04.1 [935 kB]
获取:4 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 postgresql-common all 190 [157 kB]
获取:5 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 postgresql-10 amd64 10.10-0ubuntu0.18.04.1 [3,758 kB]
获取:6 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 postgresql all 10+190 [5,784 B]
获取:7 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 sysstat amd64 11.6.1-1 [295 kB]
已下载 5,287 kB,耗时 33秒 (161 kB/s)                                          
正在预设定软件包 ...
正在选中未选择的软件包 libpq5:amd64。
(正在读取数据库 ... 系统当前共安装有 180392 个文件和目录。)
正准备解包 .../0-libpq5_10.10-0ubuntu0.18.04.1_amd64.deb  ...
正在解包 libpq5:amd64 (10.10-0ubuntu0.18.04.1) ...
正在选中未选择的软件包 postgresql-client-common。
正准备解包 .../1-postgresql-client-common_190_all.deb  ...
正在解包 postgresql-client-common (190) ...
正在选中未选择的软件包 postgresql-client-10。
正准备解包 .../2-postgresql-client-10_10.10-0ubuntu0.18.04.1_amd64.deb  ...
正在解包 postgresql-client-10 (10.10-0ubuntu0.18.04.1) ...
正在选中未选择的软件包 postgresql-common。
正准备解包 .../3-postgresql-common_190_all.deb  ...
正在添加 postgresql-common 导致 /usr/bin/pg_config 转移到 /usr/bin/pg_config.libpq-dev
正在解包 postgresql-common (190) ...
正在选中未选择的软件包 postgresql-10。
正准备解包 .../4-postgresql-10_10.10-0ubuntu0.18.04.1_amd64.deb  ...
正在解包 postgresql-10 (10.10-0ubuntu0.18.04.1) ...
正在选中未选择的软件包 postgresql。
正准备解包 .../5-postgresql_10+190_all.deb  ...
正在解包 postgresql (10+190) ...
正在选中未选择的软件包 sysstat。
正准备解包 .../6-sysstat_11.6.1-1_amd64.deb  ...
正在解包 sysstat (11.6.1-1) ...
正在设置 sysstat (11.6.1-1) ...

Creating config file /etc/default/sysstat with new version
update-alternatives: 使用 /usr/bin/sar.sysstat 来在自动模式中提供 /usr/bin/sar (sar)
Created symlink /etc/systemd/system/multi-user.target.wants/sysstat.service → /lib/systemd/system/sysstat.service.
正在设置 libpq5:amd64 (10.10-0ubuntu0.18.04.1) ...
正在设置 postgresql-client-common (190) ...
正在设置 postgresql-common (190) ...
正在将用户“postgres”加入到“ssl-cert”组中

Creating config file /etc/postgresql-common/createcluster.conf with new version
Building PostgreSQL dictionaries from installed myspell/hunspell packages...
  en_us
Removing obsolete dictionary files:
Created symlink /etc/systemd/system/multi-user.target.wants/postgresql.service → /lib/systemd/system/postgresql.service.
正在设置 postgresql-client-10 (10.10-0ubuntu0.18.04.1) ...
update-alternatives: 使用 /usr/share/postgresql/10/man/man1/psql.1.gz 来在自动模式中提供 /usr/share/man/man1/psql.1.gz (psql.1.gz)
正在设置 postgresql-10 (10.10-0ubuntu0.18.04.1) ...
Creating new PostgreSQL cluster 10/main ...
/usr/lib/postgresql/10/bin/initdb -D /var/lib/postgresql/10/main --auth-local peer --auth-host md5
The files belonging to this database system will be owned by user "postgres".
This user must also own the server process.

The database cluster will be initialized with locale "zh_CN.UTF-8".
The default database encoding has accordingly been set to "UTF8".
initdb: could not find suitable text search configuration for locale "zh_CN.UTF-8"
The default text search configuration will be set to "simple".

Data page checksums are disabled.

fixing permissions on existing directory /var/lib/postgresql/10/main ... ok
creating subdirectories ... ok
selecting default max_connections ... 100
selecting default shared_buffers ... 128MB
selecting default timezone ... Asia/Shanghai
selecting dynamic shared memory implementation ... posix
creating configuration files ... ok
running bootstrap script ... ok
performing post-bootstrap initialization ... ok
syncing data to disk ... ok

Success. You can now start the database server using:

    /usr/lib/postgresql/10/bin/pg_ctl -D /var/lib/postgresql/10/main -l logfile start

Ver Cluster Port Status Owner    Data directory              Log file
10  main    5432 down   postgres /var/lib/postgresql/10/main /var/log/postgresql/postgresql-10-main.log
update-alternatives: 使用 /usr/share/postgresql/10/man/man1/postmaster.1.gz 来在自动模式中提供 /usr/share/man/man1/postmaster.1.gz (postmaster.1.gz)
正在设置 postgresql (10+190) ...
正在处理用于 man-db (2.8.3-2ubuntu0.1) 的触发器 ...
正在处理用于 ureadahead (0.100.0-21) 的触发器 ...
ureadahead will be reprofiled on next reboot
正在处理用于 libc-bin (2.27-3ubuntu1) 的触发器 ...
正在处理用于 systemd (237-3ubuntu10.29) 的触发器 ...
root@louis-PC:~# wget -O - https://nightly.odoo.com/odoo.key | apt-key add -
--2019-10-31 19:42:48--  https://nightly.odoo.com/odoo.key
正在解析主机 nightly.odoo.com (nightly.odoo.com)... 178.33.123.40
正在连接 nightly.odoo.com (nightly.odoo.com)|178.33.123.40|:443... 已连接。
已发出 HTTP 请求,正在等待回应... 200 OK
长度: 3112 (3.0K) [application/octet-stream]
正在保存至: “STDOUT”

-                   100%[===================>]   3.04K  --.-KB/s    用时 0s    

2019-10-31 19:42:49 (114 MB/s) - 已写入至标准输出 [3112/3112]

OK
root@louis-PC:~# echo "deb http://nightly.odoo.com/13.0/nightly/deb/ ./" >> /etc/apt/sources.list.d/odoo.list
root@louis-PC:~# apt-get update && apt-get install odoo
获取:1 http://security.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB]   
忽略:2 http://nightly.odoo.com/13.0/nightly/deb ./ InRelease                   
获取:3 http://nightly.odoo.com/13.0/nightly/deb ./ Release [1,186 B]           
命中:4 http://cn.archive.ubuntu.com/ubuntu bionic InRelease                    
获取:5 http://nightly.odoo.com/13.0/nightly/deb ./ Release.gpg [819 B]         
获取:6 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages [545 kB]
获取:7 http://cn.archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]  
获取:8 http://nightly.odoo.com/13.0/nightly/deb ./ Packages [1,875 B]          
获取:9 http://cn.archive.ubuntu.com/ubuntu bionic-backports InRelease [74.6 kB]
获取:10 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main i386 Packages [601 kB]
获取:11 http://security.ubuntu.com/ubuntu bionic-security/main i386 Packages [390 kB]
获取:12 http://security.ubuntu.com/ubuntu bionic-security/main Translation-en [182 kB]
获取:13 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages [768 kB]
获取:14 http://security.ubuntu.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [38.5 kB]
获取:15 http://security.ubuntu.com/ubuntu bionic-security/main DEP-11 48x48 Icons [17.6 kB]
获取:16 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main Translation-en [275 kB]
获取:17 http://security.ubuntu.com/ubuntu bionic-security/main DEP-11 64x64 Icons [41.5 kB]
获取:18 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 DEP-11 Metadata [295 kB]
获取:19 http://security.ubuntu.com/ubuntu bionic-security/restricted amd64 Packages [9,856 B]
获取:20 http://security.ubuntu.com/ubuntu bionic-security/restricted Translation-en [3,480 B]
获取:21 http://security.ubuntu.com/ubuntu bionic-security/universe i386 Packages [595 kB]
获取:22 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 48x48 Icons [73.8 kB]
获取:23 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages [617 kB]
获取:24 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 64x64 Icons [143 kB]
获取:25 http://cn.archive.ubuntu.com/ubuntu bionic-updates/restricted amd64 Packages [16.7 kB]
获取:26 http://cn.archive.ubuntu.com/ubuntu bionic-updates/restricted Translation-en [5,144 B]
获取:27 http://security.ubuntu.com/ubuntu bionic-security/universe Translation-en [206 kB]
获取:28 http://cn.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages [1,018 kB]
获取:29 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 DEP-11 Metadata [42.1 kB]
获取:30 http://security.ubuntu.com/ubuntu bionic-security/universe DEP-11 48x48 Icons [16.4 kB]
获取:31 http://cn.archive.ubuntu.com/ubuntu bionic-updates/universe i386 Packages [985 kB]
获取:32 http://cn.archive.ubuntu.com/ubuntu bionic-updates/universe Translation-en [313 kB]
获取:33 http://cn.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 DEP-11 Metadata [254 kB]
获取:34 http://cn.archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 48x48 Icons [197 kB]
获取:35 http://cn.archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 64x64 Icons [448 kB]
获取:36 http://cn.archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64 Packages [8,096 B]
获取:37 http://cn.archive.ubuntu.com/ubuntu bionic-updates/multiverse i386 Packages [6,928 B]
获取:38 http://cn.archive.ubuntu.com/ubuntu bionic-updates/multiverse Translation-en [3,972 B]
获取:39 http://cn.archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64 DEP-11 Metadata [2,468 B]
获取:40 http://cn.archive.ubuntu.com/ubuntu bionic-backports/universe amd64 DEP-11 Metadata [7,916 B]
忽略:30 http://security.ubuntu.com/ubuntu bionic-security/universe DEP-11 48x48 Icons
获取:41 http://security.ubuntu.com/ubuntu bionic-security/universe DEP-11 64x64 Icons [111 kB]
获取:42 http://security.ubuntu.com/ubuntu bionic-security/multiverse i386 Packages [4,292 B]
获取:43 http://security.ubuntu.com/ubuntu bionic-security/multiverse amd64 Packages [5,476 B]
获取:44 http://security.ubuntu.com/ubuntu bionic-security/multiverse Translation-en [2,500 B]
获取:45 http://security.ubuntu.com/ubuntu bionic-security/multiverse amd64 DEP-11 Metadata [2,464 B]
获取:30 http://security.ubuntu.com/ubuntu bionic-security/universe DEP-11 48x48 Icons [16.4 kB]
已下载 8,492 kB,耗时 1分 18秒 (109 kB/s)                                      
正在读取软件包列表... 完成
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
下列软件包是自动安装的并且现在不需要了:
  binutils-common:i386 binutils-i686-linux-gnu gcc-7-base:i386 libasan4:i386
  libbinutils:i386 libcc1-0:i386 libcilkrts5:i386 libgcc-7-dev:i386
  libgomp1:i386 libisl19:i386 libitm1:i386 libllvm7 libmpc3:i386 libmpfr6:i386
  libmpx2:i386 libquadmath0:i386 libubsan0:i386
使用'apt autoremove'来卸载它(它们)。
将会同时安装下列软件:
  docutils-common graphviz javascript-common libann0 libcdt5 libcgraph6
  libgts-0.7-5 libgts-bin libgvc6 libgvpr2 libjs-jquery liblab-gamut1
  libpathplan4 libsass0 python-babel-localedata python-ldap python-pyasn1
  python-pyasn1-modules python3-aiohttp python3-appdirs python3-async-timeout
  python3-attr python3-babel python3-bs4 python3-cached-property
  python3-decorator python3-defusedxml python3-docutils python3-feedparser
  python3-freezegun python3-gevent python3-greenlet python3-html2text
  python3-html5lib python3-isodate python3-jinja2 python3-ldap python3-libsass
  python3-lxml python3-mock python3-multidict python3-ofxparse python3-openssl
  python3-passlib python3-pbr python3-polib python3-psutil python3-psycopg2
  python3-pyasn1 python3-pyasn1-modules python3-pydot python3-pygments
  python3-pyinotify python3-pyldap python3-pyparsing python3-pypdf2
  python3-qrcode python3-requests-toolbelt python3-roman python3-serial
  python3-stdnum python3-suds python3-usb python3-vatnumber python3-vobject
  python3-webencodings python3-werkzeug python3-xlrd python3-xlsxwriter
  python3-yarl python3-zeep sgml-base xml-core
建议安装:
  graphviz-doc apache2 | lighttpd | httpd python-attr-doc docutils-doc
  fonts-linuxlibertine | ttf-linux-libertine texlive-lang-french
  texlive-latex-base texlive-latex-recommended python-gevent-doc
  python3-gevent-dbg python-greenlet-doc python-greenlet-dev
  python3-greenlet-dbg python3-genshi python-jinja2-doc python3-lxml-dbg
  python-lxml-doc python-mock-doc python-openssl-doc python3-openssl-dbg
  python-polib-doc python-psutil-doc python-psycopg2-doc ttf-bitstream-vera
  python-pyinotify-doc python-pyparsing-doc python3-wxgtk3.0 | python3-wxgtk
  python-stdnum-doc ipython3 python3-termcolor python3-watchdog
  python-werkzeug-doc sgml-base-doc debhelper
下列【新】软件包将被安装:
  docutils-common graphviz javascript-common libann0 libcdt5 libcgraph6
  libgts-0.7-5 libgts-bin libgvc6 libgvpr2 libjs-jquery liblab-gamut1
  libpathplan4 libsass0 odoo python-babel-localedata python-ldap python-pyasn1
  python-pyasn1-modules python3-aiohttp python3-appdirs python3-async-timeout
  python3-attr python3-babel python3-bs4 python3-cached-property
  python3-decorator python3-defusedxml python3-docutils python3-feedparser
  python3-freezegun python3-gevent python3-greenlet python3-html2text
  python3-html5lib python3-isodate python3-jinja2 python3-ldap python3-libsass
  python3-lxml python3-mock python3-multidict python3-ofxparse python3-openssl
  python3-passlib python3-pbr python3-polib python3-psutil python3-psycopg2
  python3-pyasn1 python3-pyasn1-modules python3-pydot python3-pygments
  python3-pyinotify python3-pyldap python3-pyparsing python3-pypdf2
  python3-qrcode python3-requests-toolbelt python3-roman python3-serial
  python3-stdnum python3-suds python3-usb python3-vatnumber python3-vobject
  python3-webencodings python3-werkzeug python3-xlrd python3-xlsxwriter
  python3-yarl python3-zeep sgml-base xml-core
升级了 0 个软件包,新安装了 74 个软件包,要卸载 0 个软件包,有 94 个软件包未被升级。
需要下载 69.4 MB 的归档。
解压缩后会消耗 571 MB 的额外空间。
您希望继续执行吗? [Y/n] y
获取:1 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 libsass0 amd64 3.4.8-1 [708 kB]
获取:2 http://nightly.odoo.com/13.0/nightly/deb ./ odoo 13.0.20191031 [57.6 MB]
获取:3 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 sgml-base all 1.29 [12.3 kB]
获取:4 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 xml-core all 0.18 [21.3 kB]
获取:5 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 docutils-common all 0.14+dfsg-3 [156 kB]
获取:6 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 libann0 amd64 1.1.2+doc-6 [24.8 kB]
获取:7 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 libcdt5 amd64 2.40.1-2 [19.6 kB]
获取:8 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 libcgraph6 amd64 2.40.1-2 [40.8 kB]
获取:9 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 libgts-0.7-5 amd64 0.7.6+darcs121130-4 [150 kB]
获取:10 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 libpathplan4 amd64 2.40.1-2 [22.6 kB]
获取:11 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 libgvc6 amd64 2.40.1-2 [601 kB]
获取:12 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 libgvpr2 amd64 2.40.1-2 [169 kB]
获取:13 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 liblab-gamut1 amd64 2.40.1-2 [178 kB]
获取:15 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 javascript-common all 11 [6,066 B]
获取:16 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 libgts-bin amd64 0.7.6+darcs121130-4 [41.3 kB]
获取:17 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 libjs-jquery all 3.2.1-1 [152 kB]
获取:18 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 python-babel-localedata all 2.4.0+dfsg.1-2ubuntu1 [3,412 kB]
获取:14 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 graphviz amd64 2.40.1-2 [601 kB]
获取:19 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 python3-babel all 2.4.0+dfsg.1-2ubuntu1 [79.9 kB]
获取:20 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-decorator all 4.1.2-1 [9,364 B]
获取:21 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 python3-roman all 2.0.0-3 [8,624 B]
获取:22 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 python3-docutils all 0.14+dfsg-3 [363 kB]
获取:23 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 python3-feedparser all 5.2.1-1 [45.0 kB]
获取:24 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 python3-greenlet amd64 0.4.12-2 [15.2 kB]
获取:25 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-gevent amd64 1.2.2-2 [371 kB]
错误:25 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-gevent amd64 1.2.2-2
  连接超时 [IP: 91.189.91.14 80]
获取:26 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-html2text all 2018.1.9-1 [20.8 kB]
获取:27 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 python3-jinja2 all 2.10-1ubuntu0.18.04.1 [95.4 kB]
获取:28 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-libsass amd64 0.12.3-2ubuntu4 [32.1 kB]
获取:30 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 python3-pbr all 3.1.1-3ubuntu3 [53.8 kB]
获取:31 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-mock all 2.0.0-3 [47.5 kB]
获取:32 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 python3-bs4 all 4.6.0-1 [67.8 kB]
获取:33 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-ofxparse all 0.15+git20161013-1 [31.0 kB]
获取:34 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-passlib all 1.7.1-1 [347 kB]
获取:35 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 python3-polib all 1.1.0-3 [20.7 kB]
获取:29 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 python3-lxml amd64 4.2.1-1ubuntu0.1 [1,091 kB]
获取:36 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 python3-psutil amd64 5.4.2-1 [136 kB]
获取:37 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 python3-psycopg2 amd64 2.7.4-1 [152 kB]
获取:38 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 python3-pyparsing all 2.2.0+dfsg1-2 [52.2 kB]
获取:39 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-pydot all 1.2.3-1 [19.7 kB]
获取:40 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-pypdf2 all 1.26.0-2 [49.2 kB]
获取:41 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-qrcode all 5.3-1 [23.7 kB]
获取:42 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 python3-serial all 3.4-2 [56.5 kB]
获取:43 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-usb all 1.0.0-1 [37.6 kB]
获取:44 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-stdnum all 1.8.1-1 [164 kB]
获取:45 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-vatnumber all 1:1.2-7 [7,312 B]
获取:46 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-vobject all 0.9.5-1 [37.6 kB]
获取:47 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-werkzeug all 0.14.1+dfsg1-1 [174 kB]
获取:48 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 python3-xlsxwriter all 0.9.6-0.1 [145 kB]
获取:49 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-async-timeout all 2.0.0-1 [4,968 B]
获取:50 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 python3-attr all 17.4.0-2 [23.8 kB]
获取:51 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-multidict amd64 4.1.0-1 [84.1 kB]
获取:52 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-yarl amd64 1.1.0-1 [44.4 kB]
获取:53 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-aiohttp amd64 3.0.1-1 [168 kB]
获取:54 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-appdirs all 1.4.3-1 [10.4 kB]
获取:55 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-cached-property all 1.3.1-1 [7,644 B]
获取:56 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-defusedxml all 0.5.0-1ubuntu1 [19.2 kB]
获取:57 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-freezegun all 0.3.9-1 [7,088 B]
获取:58 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-isodate all 0.6.0-1 [23.9 kB]
获取:59 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-requests-toolbelt all 0.8.0-1 [35.1 kB]
获取:60 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-zeep all 2.5.0-1 [65.6 kB]
获取:61 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-suds all 0.7~git20150727.94664dd-5 [145 kB]
获取:62 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-xlrd all 1.1.0-1 [85.1 kB]
获取:63 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 python-pyasn1 all 0.4.2-3 [46.7 kB]
获取:64 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 python-pyasn1-modules all 0.2.1-0.2 [32.8 kB]
获取:65 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 python-ldap amd64 3.0.0-1 [88.9 kB]
获取:66 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 python3-webencodings all 0.5-2 [10.4 kB]
获取:67 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 python3-html5lib all 0.999999999-1 [81.9 kB]
获取:68 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 python3-pyasn1 all 0.4.2-3 [46.8 kB]
获取:69 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 python3-pyasn1-modules all 0.2.1-0.2 [32.9 kB]
获取:70 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 python3-ldap amd64 3.0.0-1 [84.0 kB]
获取:71 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 python3-openssl all 17.5.0-1ubuntu1 [41.5 kB]
获取:72 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 python3-pygments all 2.2.0+dfsg-1 [574 kB]
忽略:72 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 python3-pygments all 2.2.0+dfsg-1
获取:73 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 python3-pyinotify all 0.9.6-1 [24.7 kB]
获取:74 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-pyldap amd64 3.0.0-1 [1,084 B]
获取:72 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 python3-pygments all 2.2.0+dfsg-1 [574 kB]
已下载 68.5 MB,耗时 41分 11秒 (27.7 kB/s)                                     
E: 无法下载 http://cn.archive.ubuntu.com/ubuntu/pool/universe/p/python-gevent/python3-gevent_1.2.2-2_amd64.deb  连接超时 [IP: 91.189.91.14 80]
E: 有几个软件包无法下载,要不运行 apt-get update 或者加上 --fix-missing 的选项再试试?
root@louis-PC:~# apt-get upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
正在计算更新... 完成
下列软件包是自动安装的并且现在不需要了:
  binutils-common:i386 binutils-i686-linux-gnu gcc-7-base:i386 libasan4:i386
  libbinutils:i386 libcc1-0:i386 libcilkrts5:i386 libgcc-7-dev:i386
  libgomp1:i386 libisl19:i386 libitm1:i386 libllvm7 libmpc3:i386 libmpfr6:i386
  libmpx2:i386 libquadmath0:i386 libubsan0:i386
使用'apt autoremove'来卸载它(它们)。
下列软件包的版本将保持不变:
  linux-generic-hwe-18.04 linux-headers-generic-hwe-18.04
  linux-image-generic-hwe-18.04
下列软件包将被升级:
  apport apport-gtk apt apt-utils aspell base-files bluez bluez-cups
  bluez-obexd distro-info-data dpkg file firefox firefox-locale-en
  firefox-locale-zh-hans flashplugin-installer gdb gdbserver gir1.2-mutter-2
  gnome-control-center gnome-control-center-data gnome-control-center-faces
  gnome-initial-setup gnome-shell gnome-shell-common gnome-software
  gnome-software-common gnome-software-plugin-snap grep libapt-inst2.0
  libapt-pkg5.0 libarchive13 libaspell15 libbluetooth3 libdpkg-perl
  libegl-mesa0 libegl1-mesa libexiv2-14 libgbm1 libgl1-mesa-dri
  libgl1-mesa-dri:i386 libgl1-mesa-glx libgl1-mesa-glx:i386 libglapi-mesa
  libglapi-mesa:i386 libglx-mesa0 libglx-mesa0:i386 libidn2-0 libidn2-0:i386
  libmagic-mgc libmagic1 libmutter-2-0 libnss-myhostname libnss-systemd
  libosmesa6:i386 libpam-systemd libsane-common libsane1 libsmbclient
  libsnmp-base libsnmp30 libsystemd0 libsystemd0:i386 libtiff5 libtiff5:i386
  libudev1 libudev1:i386 libwayland-egl1-mesa libwbclient0 libwhoopsie0
  libxatracker2 libxkbcommon-x11-0 libxkbcommon0 libxslt1.1 libxslt1.1:i386
  linux-libc-dev:i386 mutter mutter-common netplan.io nplan python3-apport
  python3-problem-report samba-libs sane-utils sudo systemd systemd-sysv
  thermald ubuntu-software udev whoopsie
升级了 91 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 3 个软件包未被升级。
需要下载 105 MB 的归档。
解压缩后将会空出 24.7 MB 的空间。
您希望继续执行吗? [Y/n] Y
获取:1 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 base-files amd64 10.1ubuntu2.7 [60.3 kB]
获取:3 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 grep amd64 3.1-2build1 [159 kB]
获取:4 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libnss-systemd amd64 237-3ubuntu10.31 [105 kB]
获取:5 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libudev1 amd64 237-3ubuntu10.31 [53.9 kB]
获取:6 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main i386 libudev1 i386 237-3ubuntu10.31 [57.4 kB]
获取:7 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 bluez amd64 5.48-0ubuntu3.2 [948 kB]
获取:2 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 dpkg amd64 1.19.0.5ubuntu2.3 [1,136 kB]
获取:8 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 udev amd64 237-3ubuntu10.31 [1,102 kB]
获取:9 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libpam-systemd amd64 237-3ubuntu10.31 [108 kB]
获取:10 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libnss-myhostname amd64 237-3ubuntu10.31 [34.1 kB]
获取:12 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main i386 libsystemd0 i386 237-3ubuntu10.31 [222 kB]
获取:13 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libsystemd0 amd64 237-3ubuntu10.31 [204 kB]
获取:11 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 systemd amd64 237-3ubuntu10.31 [2,904 kB]
获取:14 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 systemd-sysv amd64 237-3ubuntu10.31 [11.7 kB]
获取:15 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libapt-pkg5.0 amd64 1.6.12 [806 kB]
获取:16 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libapt-inst2.0 amd64 1.6.12 [55.6 kB]
获取:18 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 apt-utils amd64 1.6.12 [206 kB]
获取:19 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main i386 libtiff5 i386 4.0.9-5ubuntu0.3 [164 kB]
获取:20 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libtiff5 amd64 4.0.9-5ubuntu0.3 [153 kB]
获取:17 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 apt amd64 1.6.12 [1,200 kB]
忽略:20 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libtiff5 amd64 4.0.9-5ubuntu0.3
获取:22 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libsane-common all 1.0.27-1~experimental3ubuntu2.2 [274 kB]
获取:23 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 sane-utils amd64 1.0.27-1~experimental3ubuntu2.2 [185 kB]
获取:24 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libsmbclient amd64 2:4.7.6+dfsg~ubuntu-0ubuntu2.13 [54.4 kB]
获取:21 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libsane1 amd64 1.0.27-1~experimental3ubuntu2.2 [2,088 kB]
获取:20 http://security.ubuntu.com/ubuntu bionic-updates/main amd64 libtiff5 amd64 4.0.9-5ubuntu0.3 [153 kB]
获取:25 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 samba-libs amd64 2:4.7.6+dfsg~ubuntu-0ubuntu2.13 [5,255 kB]
获取:26 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libwbclient0 amd64 2:4.7.6+dfsg~ubuntu-0ubuntu2.13 [33.2 kB]
获取:27 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 whoopsie amd64 0.2.62ubuntu0.3 [23.2 kB]
获取:28 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libwhoopsie0 amd64 0.2.62ubuntu0.3 [9,628 B]
获取:29 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main i386 libidn2-0 i386 2.0.4-1.1ubuntu0.2 [49.7 kB]
获取:30 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libidn2-0 amd64 2.0.4-1.1ubuntu0.2 [48.7 kB]
获取:31 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 distro-info-data all 0.37ubuntu0.6 [4,572 B]
获取:32 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 file amd64 1:5.32-2ubuntu0.3 [22.1 kB]
获取:33 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libmagic1 amd64 1:5.32-2ubuntu0.3 [68.7 kB]
忽略:33 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libmagic1 amd64 1:5.32-2ubuntu0.3
获取:34 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libmagic-mgc amd64 1:5.32-2ubuntu0.3 [184 kB]
获取:33 http://security.ubuntu.com/ubuntu bionic-updates/main amd64 libmagic1 amd64 1:5.32-2ubuntu0.3 [68.7 kB]
获取:35 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 netplan.io amd64 0.98-0ubuntu1~18.04.1 [64.8 kB]
获取:36 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 nplan all 0.98-0ubuntu1~18.04.1 [1,800 B]
获取:37 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 sudo amd64 1.8.21p2-3ubuntu1.1 [428 kB]
获取:38 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 python3-problem-report all 2.20.9-0ubuntu7.8 [10.5 kB]
获取:39 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 python3-apport all 2.20.9-0ubuntu7.8 [81.8 kB]
获取:40 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 apport all 2.20.9-0ubuntu7.8 [124 kB]
获取:41 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 apport-gtk all 2.20.9-0ubuntu7.8 [9,700 B]
获取:42 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 aspell amd64 0.60.7~20110707-4ubuntu0.1 [87.6 kB]
获取:43 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libaspell15 amd64 0.60.7~20110707-4ubuntu0.1 [309 kB]
忽略:43 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libaspell15 amd64 0.60.7~20110707-4ubuntu0.1
获取:44 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 bluez-cups amd64 5.48-0ubuntu3.2 [63.8 kB]
获取:43 http://security.ubuntu.com/ubuntu bionic-updates/main amd64 libaspell15 amd64 0.60.7~20110707-4ubuntu0.1 [309 kB]
获取:45 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 bluez-obexd amd64 5.48-0ubuntu3.2 [167 kB]
获取:48 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 firefox-locale-zh-hans amd64 70.0+build2-0ubuntu0.18.04.1 [493 kB]
获取:49 http://cn.archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64 flashplugin-installer amd64 32.0.0.270ubuntu0.18.04.1 [6,632 B]
获取:50 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 gdb amd64 8.1-0ubuntu3.1 [2,938 kB]
获取:52 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main i386 libosmesa6 i386 19.0.8-0ubuntu0~18.04.3 [2,430 kB]
获取:47 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 firefox-locale-en amd64 70.0+build2-0ubuntu0.18.04.1 [702 kB]
获取:46 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 firefox amd64 70.0+build2-0ubuntu0.18.04.1 [49.8 MB]
获取:51 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 gdbserver amd64 8.1-0ubuntu3.1 [282 kB]
获取:53 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main i386 libgl1-mesa-dri i386 19.0.8-0ubuntu0~18.04.3 [7,320 kB]
获取:55 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libglx-mesa0 amd64 19.0.8-0ubuntu0~18.04.3 [138 kB]
获取:54 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libgl1-mesa-dri amd64 19.0.8-0ubuntu0~18.04.3 [6,809 kB]
获取:56 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main i386 libglx-mesa0 i386 19.0.8-0ubuntu0~18.04.3 [146 kB]
获取:57 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main i386 libglapi-mesa i386 19.0.8-0ubuntu0~18.04.3 [24.9 kB]
获取:58 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libglapi-mesa amd64 19.0.8-0ubuntu0~18.04.3 [25.2 kB]
获取:59 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libegl-mesa0 amd64 19.0.8-0ubuntu0~18.04.3 [93.8 kB]
获取:60 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libgbm1 amd64 19.0.8-0ubuntu0~18.04.3 [27.0 kB]
获取:61 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libxkbcommon-x11-0 amd64 0.8.2-1~ubuntu18.04.1 [13.4 kB]
获取:62 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libxkbcommon0 amd64 0.8.2-1~ubuntu18.04.1 [97.8 kB]
获取:63 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 mutter-common all 3.28.4-0ubuntu18.04.2 [13.9 kB]
获取:64 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 gir1.2-mutter-2 amd64 3.28.4-0ubuntu18.04.2 [139 kB]
获取:66 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 gnome-control-center-data all 1:3.28.2-0ubuntu0.18.04.5 [507 kB]
获取:68 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 gnome-control-center-faces all 1:3.28.2-0ubuntu0.18.04.5 [819 kB]
获取:69 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 gnome-initial-setup amd64 3.28.0-2ubuntu6.16.04.6 [1,344 kB]
获取:71 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 gnome-shell-common all 3.28.4-0ubuntu18.04.2 [184 kB]
获取:65 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libmutter-2-0 amd64 3.28.4-0ubuntu18.04.2 [1,212 kB]
获取:67 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 gnome-control-center amd64 1:3.28.2-0ubuntu0.18.04.5 [1,629 kB]
获取:72 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 mutter amd64 3.28.4-0ubuntu18.04.2 [15.4 kB]
获取:73 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 gnome-software-plugin-snap amd64 3.28.1-0ubuntu4.18.04.12 [29.3 kB]
获取:76 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libarchive13 amd64 3.2.2-3.1ubuntu0.5 [288 kB]
获取:77 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libbluetooth3 amd64 5.48-0ubuntu3.2 [64.0 kB]
获取:70 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 gnome-shell amd64 3.28.4-0ubuntu18.04.2 [667 kB]
获取:78 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libdpkg-perl all 1.19.0.5ubuntu2.3 [211 kB]
获取:79 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libegl1-mesa amd64 19.0.8-0ubuntu0~18.04.3 [6,340 B]
获取:80 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libexiv2-14 amd64 0.25-3.1ubuntu0.18.04.4 [677 kB]
获取:81 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main i386 libgl1-mesa-glx i386 19.0.8-0ubuntu0~18.04.3 [5,392 B]
获取:82 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libgl1-mesa-glx amd64 19.0.8-0ubuntu0~18.04.3 [5,396 B]
获取:74 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 gnome-software amd64 3.28.1-0ubuntu4.18.04.12 [485 kB]
获取:83 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libsnmp-base all 5.7.3+dfsg-1.8ubuntu3.3 [224 kB]
获取:84 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libsnmp30 amd64 5.7.3+dfsg-1.8ubuntu3.3 [929 kB]
获取:85 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libwayland-egl1-mesa amd64 19.0.8-0ubuntu0~18.04.3 [6,360 B]
获取:86 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libxatracker2 amd64 19.0.8-0ubuntu0~18.04.3 [1,168 kB]
获取:75 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 gnome-software-common all 3.28.1-0ubuntu4.18.04.12 [2,482 kB]
错误:86 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libxatracker2 amd64 19.0.8-0ubuntu0~18.04.3
  连接超时 [IP: 91.189.91.26 80]
获取:87 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main i386 libxslt1.1 i386 1.1.29-5ubuntu0.2 [160 kB]
获取:88 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libxslt1.1 amd64 1.1.29-5ubuntu0.2 [150 kB]
忽略:88 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libxslt1.1 amd64 1.1.29-5ubuntu0.2
获取:88 http://security.ubuntu.com/ubuntu bionic-updates/main amd64 libxslt1.1 amd64 1.1.29-5ubuntu0.2 [150 kB]
获取:90 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 thermald amd64 1.7.0-5ubuntu5 [192 kB]
获取:91 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 ubuntu-software all 3.28.1-0ubuntu4.18.04.12 [25.3 kB]
获取:89 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main i386 linux-libc-dev i386 4.15.0-66.75 [1,139 kB]
已下载 104 MB,耗时 6分 56秒 (249 kB/s)                                        
E: 无法下载 http://cn.archive.ubuntu.com/ubuntu/pool/main/m/mesa/libxatracker2_19.0.8-0ubuntu0~18.04.3_amd64.deb  连接超时 [IP: 91.189.91.26 80]
E: 有几个软件包无法下载,要不运行 apt-get update 或者加上 --fix-missing 的选项再试试?
root@louis-PC:~# apt-get upgrade fix-missing
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
E: 无法定位软件包 fix-missing
root@louis-PC:~# apt-get upgrade --fix-missing
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
正在计算更新... 完成
下列软件包是自动安装的并且现在不需要了:
  binutils-common:i386 binutils-i686-linux-gnu gcc-7-base:i386 libasan4:i386
  libbinutils:i386 libcc1-0:i386 libcilkrts5:i386 libgcc-7-dev:i386
  libgomp1:i386 libisl19:i386 libitm1:i386 libllvm7 libmpc3:i386 libmpfr6:i386
  libmpx2:i386 libquadmath0:i386 libubsan0:i386
使用'apt autoremove'来卸载它(它们)。
下列软件包的版本将保持不变:
  linux-generic-hwe-18.04 linux-headers-generic-hwe-18.04
  linux-image-generic-hwe-18.04
下列软件包将被升级:
  apport apport-gtk apt apt-utils aspell base-files bluez bluez-cups
  bluez-obexd distro-info-data dpkg file firefox firefox-locale-en
  firefox-locale-zh-hans flashplugin-installer gdb gdbserver gir1.2-mutter-2
  gnome-control-center gnome-control-center-data gnome-control-center-faces
  gnome-initial-setup gnome-shell gnome-shell-common gnome-software
  gnome-software-common gnome-software-plugin-snap grep libapt-inst2.0
  libapt-pkg5.0 libarchive13 libaspell15 libbluetooth3 libdpkg-perl
  libegl-mesa0 libegl1-mesa libexiv2-14 libgbm1 libgl1-mesa-dri
  libgl1-mesa-dri:i386 libgl1-mesa-glx libgl1-mesa-glx:i386 libglapi-mesa
  libglapi-mesa:i386 libglx-mesa0 libglx-mesa0:i386 libidn2-0 libidn2-0:i386
  libmagic-mgc libmagic1 libmutter-2-0 libnss-myhostname libnss-systemd
  libosmesa6:i386 libpam-systemd libsane-common libsane1 libsmbclient
  libsnmp-base libsnmp30 libsystemd0 libsystemd0:i386 libtiff5 libtiff5:i386
  libudev1 libudev1:i386 libwayland-egl1-mesa libwbclient0 libwhoopsie0
  libxatracker2 libxkbcommon-x11-0 libxkbcommon0 libxslt1.1 libxslt1.1:i386
  linux-libc-dev:i386 mutter mutter-common netplan.io nplan python3-apport
  python3-problem-report samba-libs sane-utils sudo systemd systemd-sysv
  thermald ubuntu-software udev whoopsie
升级了 91 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 3 个软件包未被升级。
需要下载 1,168 kB/105 MB 的归档。
解压缩后将会空出 24.7 MB 的空间。
您希望继续执行吗? [Y/n] y
获取:1 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libxatracker2 amd64 19.0.8-0ubuntu0~18.04.3 [1,168 kB]
已下载 252 kB,耗时 14秒 (18.1 kB/s)                                           
正在从软件包中解出模板:100%
正在预设定软件包 ...
(正在读取数据库 ... 系统当前共安装有 181185 个文件和目录。)
正准备解包 .../base-files_10.1ubuntu2.7_amd64.deb  ...
Warning: Stopping motd-news.service, but it can still be activated by:
  motd-news.timer
正在将 base-files (10.1ubuntu2.7) 解包到 (10.1ubuntu2.6) 上 ...
正在设置 base-files (10.1ubuntu2.7) ...
正在安装新版本配置文件 /etc/update-motd.d/50-motd-news ...
motd-news.service is a disabled or a static unit, not starting it.
(正在读取数据库 ... 系统当前共安装有 181185 个文件和目录。)
正准备解包 .../dpkg_1.19.0.5ubuntu2.3_amd64.deb  ...
正在将 dpkg (1.19.0.5ubuntu2.3) 解包到 (1.19.0.5ubuntu2.2) 上 ...
正在设置 dpkg (1.19.0.5ubuntu2.3) ...
(正在读取数据库 ... 系统当前共安装有 181185 个文件和目录。)
正准备解包 .../grep_3.1-2build1_amd64.deb  ...
正在将 grep (3.1-2build1) 解包到 (3.1-2) 上 ...
正在设置 grep (3.1-2build1) ...
(正在读取数据库 ... 系统当前共安装有 181185 个文件和目录。)
正准备解包 .../libnss-systemd_237-3ubuntu10.31_amd64.deb  ...
正在将 libnss-systemd:amd64 (237-3ubuntu10.31) 解包到 (237-3ubuntu10.29) 上 ...
正准备解包 .../libudev1_237-3ubuntu10.31_i386.deb  ...
正在反配置 libudev1:amd64 (237-3ubuntu10.29) ...
正在将 libudev1:i386 (237-3ubuntu10.31) 解包到 (237-3ubuntu10.29) 上 ...
正准备解包 .../libudev1_237-3ubuntu10.31_amd64.deb  ...
正在将 libudev1:amd64 (237-3ubuntu10.31) 解包到 (237-3ubuntu10.29) 上 ...
正在设置 libudev1:amd64 (237-3ubuntu10.31) ...
正在设置 libudev1:i386 (237-3ubuntu10.31) ...
(正在读取数据库 ... 系统当前共安装有 181185 个文件和目录。)
正准备解包 .../0-bluez_5.48-0ubuntu3.2_amd64.deb  ...
正在将 bluez (5.48-0ubuntu3.2) 解包到 (5.48-0ubuntu3.1) 上 ...
正准备解包 .../1-udev_237-3ubuntu10.31_amd64.deb  ...
正在将 udev (237-3ubuntu10.31) 解包到 (237-3ubuntu10.29) 上 ...
正准备解包 .../2-libpam-systemd_237-3ubuntu10.31_amd64.deb  ...
正在将 libpam-systemd:amd64 (237-3ubuntu10.31) 解包到 (237-3ubuntu10.29) 上 ...
正准备解包 .../3-libnss-myhostname_237-3ubuntu10.31_amd64.deb  ...
正在将 libnss-myhostname:amd64 (237-3ubuntu10.31) 解包到 (237-3ubuntu10.29) 上 ...
正准备解包 .../4-systemd_237-3ubuntu10.31_amd64.deb  ...
正在将 systemd (237-3ubuntu10.31) 解包到 (237-3ubuntu10.29) 上 ...
正准备解包 .../5-libsystemd0_237-3ubuntu10.31_amd64.deb  ...
正在反配置 libsystemd0:i386 (237-3ubuntu10.29) ...
正在将 libsystemd0:amd64 (237-3ubuntu10.31) 解包到 (237-3ubuntu10.29) 上 ...
正准备解包 .../6-libsystemd0_237-3ubuntu10.31_i386.deb  ...
正在将 libsystemd0:i386 (237-3ubuntu10.31) 解包到 (237-3ubuntu10.29) 上 ...
正在设置 libsystemd0:amd64 (237-3ubuntu10.31) ...
正在设置 libsystemd0:i386 (237-3ubuntu10.31) ...
正在设置 systemd (237-3ubuntu10.31) ...
(正在读取数据库 ... 系统当前共安装有 181185 个文件和目录。)
正准备解包 .../systemd-sysv_237-3ubuntu10.31_amd64.deb  ...
正在将 systemd-sysv (237-3ubuntu10.31) 解包到 (237-3ubuntu10.29) 上 ...
正准备解包 .../libapt-pkg5.0_1.6.12_amd64.deb  ...
正在将 libapt-pkg5.0:amd64 (1.6.12) 解包到 (1.6.11) 上 ...
正在设置 libapt-pkg5.0:amd64 (1.6.12) ...
(正在读取数据库 ... 系统当前共安装有 181185 个文件和目录。)
正准备解包 .../libapt-inst2.0_1.6.12_amd64.deb  ...
正在将 libapt-inst2.0:amd64 (1.6.12) 解包到 (1.6.11) 上 ...
正准备解包 .../archives/apt_1.6.12_amd64.deb  ...
正在将 apt (1.6.12) 解包到 (1.6.11) 上 ...
正在设置 apt (1.6.12) ...
(正在读取数据库 ... 系统当前共安装有 181191 个文件和目录。)
正准备解包 .../00-apt-utils_1.6.12_amd64.deb  ...
正在将 apt-utils (1.6.12) 解包到 (1.6.11) 上 ...
正准备解包 .../01-libtiff5_4.0.9-5ubuntu0.3_amd64.deb  ...
正在反配置 libtiff5:i386 (4.0.9-5ubuntu0.2) ...
正在将 libtiff5:amd64 (4.0.9-5ubuntu0.3) 解包到 (4.0.9-5ubuntu0.2) 上 ...
正准备解包 .../02-libtiff5_4.0.9-5ubuntu0.3_i386.deb  ...
正在将 libtiff5:i386 (4.0.9-5ubuntu0.3) 解包到 (4.0.9-5ubuntu0.2) 上 ...
正准备解包 .../03-libsane1_1.0.27-1~experimental3ubuntu2.2_amd64.deb  ...
正在将 libsane1:amd64 (1.0.27-1~experimental3ubuntu2.2) 解包到 (1.0.27-1~experimental3ubuntu2.1) 上 ...
正准备解包 .../04-libsane-common_1.0.27-1~experimental3ubuntu2.2_all.deb  ...
正在将 libsane-common (1.0.27-1~experimental3ubuntu2.2) 解包到 (1.0.27-1~experimental3ubuntu2.1) 上 ...
正准备解包 .../05-sane-utils_1.0.27-1~experimental3ubuntu2.2_amd64.deb  ...
正在将 sane-utils (1.0.27-1~experimental3ubuntu2.2) 解包到 (1.0.27-1~experimental3ubuntu2.1) 上 ...
正准备解包 .../06-libsmbclient_2%3a4.7.6+dfsg~ubuntu-0ubuntu2.13_amd64.deb  ...
正在将 libsmbclient:amd64 (2:4.7.6+dfsg~ubuntu-0ubuntu2.13) 解包到 (2:4.7.6+dfsg~ubuntu-0ubuntu2.11) 上 ...
正准备解包 .../07-samba-libs_2%3a4.7.6+dfsg~ubuntu-0ubuntu2.13_amd64.deb  ...
正在将 samba-libs:amd64 (2:4.7.6+dfsg~ubuntu-0ubuntu2.13) 解包到 (2:4.7.6+dfsg~ubuntu-0ubuntu2.11) 上 ...
正准备解包 .../08-libwbclient0_2%3a4.7.6+dfsg~ubuntu-0ubuntu2.13_amd64.deb  ...
正在将 libwbclient0:amd64 (2:4.7.6+dfsg~ubuntu-0ubuntu2.13) 解包到 (2:4.7.6+dfsg~ubuntu-0ubuntu2.11) 上 ...
正准备解包 .../09-whoopsie_0.2.62ubuntu0.3_amd64.deb  ...
正在将 whoopsie (0.2.62ubuntu0.3) 解包到 (0.2.62ubuntu0.1) 上 ...
正准备解包 .../10-libwhoopsie0_0.2.62ubuntu0.3_amd64.deb  ...
正在将 libwhoopsie0:amd64 (0.2.62ubuntu0.3) 解包到 (0.2.62ubuntu0.1) 上 ...
正准备解包 .../11-libidn2-0_2.0.4-1.1ubuntu0.2_amd64.deb  ...
正在反配置 libidn2-0:i386 (2.0.4-1.1build2) ...
正在将 libidn2-0:amd64 (2.0.4-1.1ubuntu0.2) 解包到 (2.0.4-1.1build2) 上 ...
正准备解包 .../12-libidn2-0_2.0.4-1.1ubuntu0.2_i386.deb  ...
正在将 libidn2-0:i386 (2.0.4-1.1ubuntu0.2) 解包到 (2.0.4-1.1build2) 上 ...
正准备解包 .../13-distro-info-data_0.37ubuntu0.6_all.deb  ...
正在将 distro-info-data (0.37ubuntu0.6) 解包到 (0.37ubuntu0.5) 上 ...
正准备解包 .../14-file_1%3a5.32-2ubuntu0.3_amd64.deb  ...
正在将 file (1:5.32-2ubuntu0.3) 解包到 (1:5.32-2ubuntu0.2) 上 ...
正准备解包 .../15-libmagic1_1%3a5.32-2ubuntu0.3_amd64.deb  ...
正在将 libmagic1:amd64 (1:5.32-2ubuntu0.3) 解包到 (1:5.32-2ubuntu0.2) 上 ...
正准备解包 .../16-libmagic-mgc_1%3a5.32-2ubuntu0.3_amd64.deb  ...
正在将 libmagic-mgc (1:5.32-2ubuntu0.3) 解包到 (1:5.32-2ubuntu0.2) 上 ...
正准备解包 .../17-netplan.io_0.98-0ubuntu1~18.04.1_amd64.deb  ...
正在将 netplan.io (0.98-0ubuntu1~18.04.1) 解包到 (0.97-0ubuntu1~18.04.1) 上 ...
正准备解包 .../18-nplan_0.98-0ubuntu1~18.04.1_all.deb  ...
正在将 nplan (0.98-0ubuntu1~18.04.1) 解包到 (0.97-0ubuntu1~18.04.1) 上 ...
正准备解包 .../19-sudo_1.8.21p2-3ubuntu1.1_amd64.deb  ...
正在将 sudo (1.8.21p2-3ubuntu1.1) 解包到 (1.8.21p2-3ubuntu1) 上 ...
正准备解包 .../20-python3-problem-report_2.20.9-0ubuntu7.8_all.deb  ...
正在将 python3-problem-report (2.20.9-0ubuntu7.8) 解包到 (2.20.9-0ubuntu7.7) 上 ...
正准备解包 .../21-python3-apport_2.20.9-0ubuntu7.8_all.deb  ...
正在将 python3-apport (2.20.9-0ubuntu7.8) 解包到 (2.20.9-0ubuntu7.7) 上 ...
正准备解包 .../22-apport_2.20.9-0ubuntu7.8_all.deb  ...
正在将 apport (2.20.9-0ubuntu7.8) 解包到 (2.20.9-0ubuntu7.7) 上 ...
正准备解包 .../23-apport-gtk_2.20.9-0ubuntu7.8_all.deb  ...
正在将 apport-gtk (2.20.9-0ubuntu7.8) 解包到 (2.20.9-0ubuntu7.7) 上 ...
正准备解包 .../24-aspell_0.60.7~20110707-4ubuntu0.1_amd64.deb  ...
正在将 aspell (0.60.7~20110707-4ubuntu0.1) 解包到 (0.60.7~20110707-4) 上 ...
正准备解包 .../25-libaspell15_0.60.7~20110707-4ubuntu0.1_amd64.deb  ...
正在将 libaspell15:amd64 (0.60.7~20110707-4ubuntu0.1) 解包到 (0.60.7~20110707-4) 上 ...
正准备解包 .../26-bluez-cups_5.48-0ubuntu3.2_amd64.deb  ...
正在将 bluez-cups (5.48-0ubuntu3.2) 解包到 (5.48-0ubuntu3.1) 上 ...
正准备解包 .../27-bluez-obexd_5.48-0ubuntu3.2_amd64.deb  ...
正在将 bluez-obexd (5.48-0ubuntu3.2) 解包到 (5.48-0ubuntu3.1) 上 ...
正准备解包 .../28-firefox_70.0+build2-0ubuntu0.18.04.1_amd64.deb  ...
正在将 firefox (70.0+build2-0ubuntu0.18.04.1) 解包到 (69.0.2+build1-0ubuntu0.18.04.1) 上 ...
正准备解包 .../29-firefox-locale-en_70.0+build2-0ubuntu0.18.04.1_amd64.deb  ...
正在将 firefox-locale-en (70.0+build2-0ubuntu0.18.04.1) 解包到 (69.0.2+build1-0ubuntu0.18.04.1) 上 ...
正准备解包 .../30-firefox-locale-zh-hans_70.0+build2-0ubuntu0.18.04.1_amd64.deb  ...
正在将 firefox-locale-zh-hans (70.0+build2-0ubuntu0.18.04.1) 解包到 (69.0.2+build1-0ubuntu0.18.04.1) 上 ...
正准备解包 .../31-flashplugin-installer_32.0.0.270ubuntu0.18.04.1_amd64.deb  ...
正在将 flashplugin-installer (32.0.0.270ubuntu0.18.04.1) 解包到 (32.0.0.255ubuntu0.18.04.1) 上 ...
正准备解包 .../32-gdb_8.1-0ubuntu3.1_amd64.deb  ...
正在将 gdb (8.1-0ubuntu3.1) 解包到 (8.1-0ubuntu3) 上 ...
正准备解包 .../33-gdbserver_8.1-0ubuntu3.1_amd64.deb  ...
正在将 gdbserver (8.1-0ubuntu3.1) 解包到 (8.1-0ubuntu3) 上 ...
正准备解包 .../34-libosmesa6_19.0.8-0ubuntu0~18.04.3_i386.deb  ...
正在将 libosmesa6:i386 (19.0.8-0ubuntu0~18.04.3) 解包到 (19.0.8-0ubuntu0~18.04.1) 上 ...
正准备解包 .../35-libgl1-mesa-dri_19.0.8-0ubuntu0~18.04.3_amd64.deb  ...
正在反配置 libgl1-mesa-dri:i386 (19.0.8-0ubuntu0~18.04.1) ...
正在将 libgl1-mesa-dri:amd64 (19.0.8-0ubuntu0~18.04.3) 解包到 (19.0.8-0ubuntu0~18.04.1) 上 ...
正准备解包 .../36-libgl1-mesa-dri_19.0.8-0ubuntu0~18.04.3_i386.deb  ...
正在将 libgl1-mesa-dri:i386 (19.0.8-0ubuntu0~18.04.3) 解包到 (19.0.8-0ubuntu0~18.04.1) 上 ...
正准备解包 .../37-libglx-mesa0_19.0.8-0ubuntu0~18.04.3_i386.deb  ...
正在反配置 libglx-mesa0:amd64 (19.0.8-0ubuntu0~18.04.1) ...
正在将 libglx-mesa0:i386 (19.0.8-0ubuntu0~18.04.3) 解包到 (19.0.8-0ubuntu0~18.04.1) 上 ...
正准备解包 .../38-libglx-mesa0_19.0.8-0ubuntu0~18.04.3_amd64.deb  ...
正在将 libglx-mesa0:amd64 (19.0.8-0ubuntu0~18.04.3) 解包到 (19.0.8-0ubuntu0~18.04.1) 上 ...
正准备解包 .../39-libglapi-mesa_19.0.8-0ubuntu0~18.04.3_amd64.deb  ...
正在反配置 libglapi-mesa:i386 (19.0.8-0ubuntu0~18.04.1) ...
正在将 libglapi-mesa:amd64 (19.0.8-0ubuntu0~18.04.3) 解包到 (19.0.8-0ubuntu0~18.04.1) 上 ...
正准备解包 .../40-libglapi-mesa_19.0.8-0ubuntu0~18.04.3_i386.deb  ...
正在将 libglapi-mesa:i386 (19.0.8-0ubuntu0~18.04.3) 解包到 (19.0.8-0ubuntu0~18.04.1) 上 ...
正准备解包 .../41-libegl-mesa0_19.0.8-0ubuntu0~18.04.3_amd64.deb  ...
正在将 libegl-mesa0:amd64 (19.0.8-0ubuntu0~18.04.3) 解包到 (19.0.8-0ubuntu0~18.04.1) 上 ...
正准备解包 .../42-libgbm1_19.0.8-0ubuntu0~18.04.3_amd64.deb  ...
正在将 libgbm1:amd64 (19.0.8-0ubuntu0~18.04.3) 解包到 (19.0.8-0ubuntu0~18.04.1) 上 ...
正准备解包 .../43-libxkbcommon-x11-0_0.8.2-1~ubuntu18.04.1_amd64.deb  ...
正在将 libxkbcommon-x11-0:amd64 (0.8.2-1~ubuntu18.04.1) 解包到 (0.8.0-1ubuntu0.1) 上 ...
正准备解包 .../44-libxkbcommon0_0.8.2-1~ubuntu18.04.1_amd64.deb  ...
正在将 libxkbcommon0:amd64 (0.8.2-1~ubuntu18.04.1) 解包到 (0.8.0-1ubuntu0.1) 上 ...
正准备解包 .../45-mutter-common_3.28.4-0ubuntu18.04.2_all.deb  ...
正在将 mutter-common (3.28.4-0ubuntu18.04.2) 解包到 (3.28.4-0ubuntu18.04.1) 上 ...
正准备解包 .../46-gir1.2-mutter-2_3.28.4-0ubuntu18.04.2_amd64.deb  ...
正在将 gir1.2-mutter-2:amd64 (3.28.4-0ubuntu18.04.2) 解包到 (3.28.4-0ubuntu18.04.1) 上 ...
正准备解包 .../47-libmutter-2-0_3.28.4-0ubuntu18.04.2_amd64.deb  ...
正在将 libmutter-2-0:amd64 (3.28.4-0ubuntu18.04.2) 解包到 (3.28.4-0ubuntu18.04.1) 上 ...
正准备解包 .../48-gnome-control-center-data_1%3a3.28.2-0ubuntu0.18.04.5_all.deb  ...
正在将 gnome-control-center-data (1:3.28.2-0ubuntu0.18.04.5) 解包到 (1:3.28.2-0ubuntu0.18.04.4) 上 ...
正准备解包 .../49-gnome-control-center_1%3a3.28.2-0ubuntu0.18.04.5_amd64.deb  ...
正在将 gnome-control-center (1:3.28.2-0ubuntu0.18.04.5) 解包到 (1:3.28.2-0ubuntu0.18.04.4) 上 ...
正准备解包 .../50-gnome-control-center-faces_1%3a3.28.2-0ubuntu0.18.04.5_all.deb  ...
正在将 gnome-control-center-faces (1:3.28.2-0ubuntu0.18.04.5) 解包到 (1:3.28.2-0ubuntu0.18.04.4) 上 ...
正准备解包 .../51-gnome-initial-setup_3.28.0-2ubuntu6.16.04.6_amd64.deb  ...
正在将 gnome-initial-setup (3.28.0-2ubuntu6.16.04.6) 解包到 (3.28.0-2ubuntu6.16.04.4) 上 ...
正准备解包 .../52-gnome-shell_3.28.4-0ubuntu18.04.2_amd64.deb  ...
正在将 gnome-shell (3.28.4-0ubuntu18.04.2) 解包到 (3.28.4-0ubuntu18.04.1) 上 ...
正准备解包 .../53-gnome-shell-common_3.28.4-0ubuntu18.04.2_all.deb  ...
正在将 gnome-shell-common (3.28.4-0ubuntu18.04.2) 解包到 (3.28.4-0ubuntu18.04.1) 上 ...
正准备解包 .../54-mutter_3.28.4-0ubuntu18.04.2_amd64.deb  ...
正在将 mutter (3.28.4-0ubuntu18.04.2) 解包到 (3.28.4-0ubuntu18.04.1) 上 ...
正准备解包 .../55-gnome-software-plugin-snap_3.28.1-0ubuntu4.18.04.12_amd64.deb  ...
正在将 gnome-software-plugin-snap (3.28.1-0ubuntu4.18.04.12) 解包到 (3.28.1-0ubuntu4.18.04.10) 上 ...
正准备解包 .../56-gnome-software_3.28.1-0ubuntu4.18.04.12_amd64.deb  ...
正在将 gnome-software (3.28.1-0ubuntu4.18.04.12) 解包到 (3.28.1-0ubuntu4.18.04.10) 上 ...
正准备解包 .../57-gnome-software-common_3.28.1-0ubuntu4.18.04.12_all.deb  ...
正在将 gnome-software-common (3.28.1-0ubuntu4.18.04.12) 解包到 (3.28.1-0ubuntu4.18.04.10) 上 ...
正准备解包 .../58-libarchive13_3.2.2-3.1ubuntu0.5_amd64.deb  ...
正在将 libarchive13:amd64 (3.2.2-3.1ubuntu0.5) 解包到 (3.2.2-3.1ubuntu0.4) 上 ...
正准备解包 .../59-libbluetooth3_5.48-0ubuntu3.2_amd64.deb  ...
正在将 libbluetooth3:amd64 (5.48-0ubuntu3.2) 解包到 (5.48-0ubuntu3.1) 上 ...
正准备解包 .../60-libdpkg-perl_1.19.0.5ubuntu2.3_all.deb  ...
正在将 libdpkg-perl (1.19.0.5ubuntu2.3) 解包到 (1.19.0.5ubuntu2.2) 上 ...
正准备解包 .../61-libegl1-mesa_19.0.8-0ubuntu0~18.04.3_amd64.deb  ...
正在将 libegl1-mesa:amd64 (19.0.8-0ubuntu0~18.04.3) 解包到 (19.0.8-0ubuntu0~18.04.1) 上 ...
正准备解包 .../62-libexiv2-14_0.25-3.1ubuntu0.18.04.4_amd64.deb  ...
正在将 libexiv2-14:amd64 (0.25-3.1ubuntu0.18.04.4) 解包到 (0.25-3.1ubuntu0.18.04.3) 上 ...
正准备解包 .../63-libgl1-mesa-glx_19.0.8-0ubuntu0~18.04.3_i386.deb  ...
正在反配置 libgl1-mesa-glx:amd64 (19.0.8-0ubuntu0~18.04.1) ...
正在将 libgl1-mesa-glx:i386 (19.0.8-0ubuntu0~18.04.3) 解包到 (19.0.8-0ubuntu0~18.04.1) 上 ...
正准备解包 .../64-libgl1-mesa-glx_19.0.8-0ubuntu0~18.04.3_amd64.deb  ...
正在将 libgl1-mesa-glx:amd64 (19.0.8-0ubuntu0~18.04.3) 解包到 (19.0.8-0ubuntu0~18.04.1) 上 ...
正准备解包 .../65-libsnmp-base_5.7.3+dfsg-1.8ubuntu3.3_all.deb  ...
正在将 libsnmp-base (5.7.3+dfsg-1.8ubuntu3.3) 解包到 (5.7.3+dfsg-1.8ubuntu3.1) 上 ...
正准备解包 .../66-libsnmp30_5.7.3+dfsg-1.8ubuntu3.3_amd64.deb  ...
正在将 libsnmp30:amd64 (5.7.3+dfsg-1.8ubuntu3.3) 解包到 (5.7.3+dfsg-1.8ubuntu3.1) 上 ...
正准备解包 .../67-libwayland-egl1-mesa_19.0.8-0ubuntu0~18.04.3_amd64.deb  ...
正在将 libwayland-egl1-mesa:amd64 (19.0.8-0ubuntu0~18.04.3) 解包到 (19.0.8-0ubuntu0~18.04.1) 上 ...
正准备解包 .../68-libxatracker2_19.0.8-0ubuntu0~18.04.3_amd64.deb  ...
正在将 libxatracker2:amd64 (19.0.8-0ubuntu0~18.04.3) 解包到 (19.0.8-0ubuntu0~18.04.1) 上 ...
正准备解包 .../69-libxslt1.1_1.1.29-5ubuntu0.2_i386.deb  ...
正在反配置 libxslt1.1:amd64 (1.1.29-5ubuntu0.1) ...
正在将 libxslt1.1:i386 (1.1.29-5ubuntu0.2) 解包到 (1.1.29-5ubuntu0.1) 上 ...
正准备解包 .../70-libxslt1.1_1.1.29-5ubuntu0.2_amd64.deb  ...
正在将 libxslt1.1:amd64 (1.1.29-5ubuntu0.2) 解包到 (1.1.29-5ubuntu0.1) 上 ...
正准备解包 .../71-linux-libc-dev_4.15.0-66.75_i386.deb  ...
正在将 linux-libc-dev:i386 (4.15.0-66.75) 解包到 (4.15.0-65.74) 上 ...
正准备解包 .../72-thermald_1.7.0-5ubuntu5_amd64.deb  ...
正在将 thermald (1.7.0-5ubuntu5) 解包到 (1.7.0-5ubuntu2) 上 ...
正准备解包 .../73-ubuntu-software_3.28.1-0ubuntu4.18.04.12_all.deb  ...
正在将 ubuntu-software (3.28.1-0ubuntu4.18.04.12) 解包到 (3.28.1-0ubuntu4.18.04.10) 上 ...
正在设置 libapt-inst2.0:amd64 (1.6.12) ...
正在设置 libnss-systemd:amd64 (237-3ubuntu10.31) ...
正在设置 libwbclient0:amd64 (2:4.7.6+dfsg~ubuntu-0ubuntu2.13) ...
正在设置 libexiv2-14:amd64 (0.25-3.1ubuntu0.18.04.4) ...
正在设置 gnome-software-common (3.28.1-0ubuntu4.18.04.12) ...
正在设置 libidn2-0:amd64 (2.0.4-1.1ubuntu0.2) ...
正在设置 libidn2-0:i386 (2.0.4-1.1ubuntu0.2) ...
正在设置 samba-libs:amd64 (2:4.7.6+dfsg~ubuntu-0ubuntu2.13) ...
正在设置 firefox-locale-en (70.0+build2-0ubuntu0.18.04.1) ...
正在设置 libnss-myhostname:amd64 (237-3ubuntu10.31) ...
正在设置 sudo (1.8.21p2-3ubuntu1.1) ...
正在设置 thermald (1.7.0-5ubuntu5) ...
正在设置 libaspell15:amd64 (0.60.7~20110707-4ubuntu0.1) ...
正在设置 libarchive13:amd64 (3.2.2-3.1ubuntu0.5) ...
正在设置 apt-utils (1.6.12) ...
正在设置 bluez-cups (5.48-0ubuntu3.2) ...
正在设置 systemd-sysv (237-3ubuntu10.31) ...
正在设置 mutter-common (3.28.4-0ubuntu18.04.2) ...
正在设置 libgbm1:amd64 (19.0.8-0ubuntu0~18.04.3) ...
正在设置 libbluetooth3:amd64 (5.48-0ubuntu3.2) ...
正在设置 linux-libc-dev:i386 (4.15.0-66.75) ...
正在设置 libdpkg-perl (1.19.0.5ubuntu2.3) ...
正在设置 distro-info-data (0.37ubuntu0.6) ...
正在设置 libtiff5:amd64 (4.0.9-5ubuntu0.3) ...
正在设置 libtiff5:i386 (4.0.9-5ubuntu0.3) ...
正在设置 libglapi-mesa:amd64 (19.0.8-0ubuntu0~18.04.3) ...
正在设置 libglapi-mesa:i386 (19.0.8-0ubuntu0~18.04.3) ...
正在设置 netplan.io (0.98-0ubuntu1~18.04.1) ...
正在设置 libxatracker2:amd64 (19.0.8-0ubuntu0~18.04.3) ...
正在设置 libmagic-mgc (1:5.32-2ubuntu0.3) ...
正在设置 libsmbclient:amd64 (2:4.7.6+dfsg~ubuntu-0ubuntu2.13) ...
正在设置 gnome-control-center-faces (1:3.28.2-0ubuntu0.18.04.5) ...
正在设置 libmagic1:amd64 (1:5.32-2ubuntu0.3) ...
正在设置 libsane-common (1.0.27-1~experimental3ubuntu2.2) ...
正在设置 libxslt1.1:amd64 (1.1.29-5ubuntu0.2) ...
正在设置 libxslt1.1:i386 (1.1.29-5ubuntu0.2) ...
正在设置 gnome-shell-common (3.28.4-0ubuntu18.04.2) ...
正在设置 python3-problem-report (2.20.9-0ubuntu7.8) ...
正在设置 gnome-control-center-data (1:3.28.2-0ubuntu0.18.04.5) ...
正在设置 udev (237-3ubuntu10.31) ...
update-initramfs: deferring update (trigger activated)
正在设置 nplan (0.98-0ubuntu1~18.04.1) ...
正在设置 gnome-software (3.28.1-0ubuntu4.18.04.12) ...
正在设置 bluez-obexd (5.48-0ubuntu3.2) ...
正在设置 libwayland-egl1-mesa:amd64 (19.0.8-0ubuntu0~18.04.3) ...
正在设置 firefox (70.0+build2-0ubuntu0.18.04.1) ...
Please restart all running instances of firefox, or you will experience problems.
正在设置 libxkbcommon0:amd64 (0.8.2-1~ubuntu18.04.1) ...
正在设置 libsane1:amd64 (1.0.27-1~experimental3ubuntu2.2) ...
正在设置 gdbserver (8.1-0ubuntu3.1) ...
正在设置 libegl-mesa0:amd64 (19.0.8-0ubuntu0~18.04.3) ...
正在设置 aspell (0.60.7~20110707-4ubuntu0.1) ...
正在设置 firefox-locale-zh-hans (70.0+build2-0ubuntu0.18.04.1) ...
正在设置 bluez (5.48-0ubuntu3.2) ...
正在设置 flashplugin-installer (32.0.0.270ubuntu0.18.04.1) ...
正在设置 sane-utils (1.0.27-1~experimental3ubuntu2.2) ...
正在设置 gdb (8.1-0ubuntu3.1) ...
正在设置 libwhoopsie0:amd64 (0.2.62ubuntu0.3) ...
正在设置 libegl1-mesa:amd64 (19.0.8-0ubuntu0~18.04.3) ...
正在设置 libsnmp-base (5.7.3+dfsg-1.8ubuntu3.3) ...
正在设置 libsnmp30:amd64 (5.7.3+dfsg-1.8ubuntu3.3) ...
正在设置 libpam-systemd:amd64 (237-3ubuntu10.31) ...
正在设置 libosmesa6:i386 (19.0.8-0ubuntu0~18.04.3) ...
正在设置 libgl1-mesa-dri:amd64 (19.0.8-0ubuntu0~18.04.3) ...
正在设置 libgl1-mesa-dri:i386 (19.0.8-0ubuntu0~18.04.3) ...
正在设置 file (1:5.32-2ubuntu0.3) ...
正在设置 python3-apport (2.20.9-0ubuntu7.8) ...
正在设置 libxkbcommon-x11-0:amd64 (0.8.2-1~ubuntu18.04.1) ...
正在设置 whoopsie (0.2.62ubuntu0.3) ...
正在设置 apport (2.20.9-0ubuntu7.8) ...
apport-autoreport.service is a disabled or a static unit, not starting it.
正在设置 libglx-mesa0:amd64 (19.0.8-0ubuntu0~18.04.3) ...
正在设置 libglx-mesa0:i386 (19.0.8-0ubuntu0~18.04.3) ...
正在设置 apport-gtk (2.20.9-0ubuntu7.8) ...
正在设置 libgl1-mesa-glx:amd64 (19.0.8-0ubuntu0~18.04.3) ...
正在设置 libgl1-mesa-glx:i386 (19.0.8-0ubuntu0~18.04.3) ...
正在处理用于 mime-support (3.60ubuntu1) 的触发器 ...
正在处理用于 ureadahead (0.100.0-21) 的触发器 ...
正在处理用于 update-notifier-common (3.192.1.7) 的触发器 ...
flashplugin-installer: processing...
flashplugin-installer: downloading http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_20191009.1.orig.tar.gz
获取:1 http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_20191009.1.orig.tar.gz [30.6 MB]
已下载 30.6 MB,耗时 34分 21秒 (14.8 kB/s)                                     
Installing from local file /var/lib/update-notifier/package-data-downloads/partial/adobe-flashplugin_20191009.1.orig.tar.gz
Flash Plugin installed.
正在处理用于 desktop-file-utils (0.23-1ubuntu3.18.04.2) 的触发器 ...
正在处理用于 install-info (6.5.0.dfsg.1-2) 的触发器 ...
正在处理用于 plymouth-theme-ubuntu-text (0.9.3-1ubuntu7.18.04.2) 的触发器 ...
update-initramfs: deferring update (trigger activated)
正在处理用于 cracklib-runtime (2.9.2-5build1) 的触发器 ...
正在处理用于 libglib2.0-0:amd64 (2.56.4-0ubuntu0.18.04.4) 的触发器 ...
正在设置 gnome-software-plugin-snap (3.28.1-0ubuntu4.18.04.12) ...
正在设置 gnome-control-center (1:3.28.2-0ubuntu0.18.04.5) ...
正在处理用于 libc-bin (2.27-3ubuntu1) 的触发器 ...
正在处理用于 systemd (237-3ubuntu10.31) 的触发器 ...
正在设置 gnome-initial-setup (3.28.0-2ubuntu6.16.04.6) ...
正在处理用于 man-db (2.8.3-2ubuntu0.1) 的触发器 ...
正在处理用于 gnome-menus (3.13.3-11ubuntu1.1) 的触发器 ...
正在处理用于 dbus (1.12.2-1ubuntu1.1) 的触发器 ...
正在处理用于 hicolor-icon-theme (0.17-2) 的触发器 ...
正在设置 ubuntu-software (3.28.1-0ubuntu4.18.04.12) ...
正在设置 libmutter-2-0:amd64 (3.28.4-0ubuntu18.04.2) ...
正在设置 gir1.2-mutter-2:amd64 (3.28.4-0ubuntu18.04.2) ...
正在设置 mutter (3.28.4-0ubuntu18.04.2) ...
正在设置 gnome-shell (3.28.4-0ubuntu18.04.2) ...
正在处理用于 initramfs-tools (0.130ubuntu3.8) 的触发器 ...
update-initramfs: Generating /boot/initrd.img-5.0.0-31-generic
正在处理用于 dictionaries-common (1.27.2) 的触发器 ...
正在处理用于 libc-bin (2.27-3ubuntu1) 的触发器 ...
root@louis-PC:~# sudo systemctl start postgresql
root@louis-PC:~# su - postgres
postgres@louis-PC:~$ createuser --createdb --username postgres --no-createrole --no-superuser --pwprompt odoo
Enter password for new role: 
Enter it again: 
postgres@louis-PC:~$ exit
注销
root@louis-PC:~# netstat -plntu 

Command 'netstat' not found, but can be installed with:

apt install net-tools

root@louis-PC:~# apt install net-tools
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
下列软件包是自动安装的并且现在不需要了:
  binutils-common:i386 binutils-i686-linux-gnu gcc-7-base:i386 libasan4:i386
  libbinutils:i386 libcc1-0:i386 libcilkrts5:i386 libgcc-7-dev:i386
  libgomp1:i386 libisl19:i386 libitm1:i386 libllvm7 libmpc3:i386 libmpfr6:i386
  libmpx2:i386 libquadmath0:i386 libubsan0:i386
使用'apt autoremove'来卸载它(它们)。
下列【新】软件包将被安装:
  net-tools
升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 3 个软件包未被升级。
需要下载 194 kB 的归档。
解压缩后会消耗 803 kB 的额外空间。
获取:1 http://cn.archive.ubuntu.com/ubuntu bionic/main amd64 net-tools amd64 1.60+git20161116.90da8a0-1ubuntu1 [194 kB]
已下载 194 kB,耗时 14秒 (13.7 kB/s)                                           
正在选中未选择的软件包 net-tools。
(正在读取数据库 ... 系统当前共安装有 181196 个文件和目录。)
正准备解包 .../net-tools_1.60+git20161116.90da8a0-1ubuntu1_amd64.deb  ...
正在解包 net-tools (1.60+git20161116.90da8a0-1ubuntu1) ...
正在设置 net-tools (1.60+git20161116.90da8a0-1ubuntu1) ...
正在处理用于 man-db (2.8.3-2ubuntu0.1) 的触发器 ...
root@louis-PC:~# netstat -plntu 
激活Internet连接 (仅服务器)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name    
tcp        0      0 127.0.0.53:53           0.0.0.0:*               LISTEN      8068/systemd-resolv 
tcp        0      0 127.0.0.1:631           0.0.0.0:*               LISTEN      2779/cupsd          
tcp        0      0 127.0.0.1:5432          0.0.0.0:*               LISTEN      4375/postgres       
tcp6       0      0 ::1:631                 :::*                    LISTEN      2779/cupsd          
udp        0      0 127.0.0.53:53           0.0.0.0:*                           8068/systemd-resolv 
udp        0      0 0.0.0.0:68              0.0.0.0:*                           2433/dhclient       
udp        0      0 0.0.0.0:53400           0.0.0.0:*                           1027/avahi-daemon:  
udp        0      0 0.0.0.0:631             0.0.0.0:*                           2780/cups-browsed   
udp        0      0 0.0.0.0:5353            0.0.0.0:*                           1027/avahi-daemon:  
udp6       0      0 :::5353                 :::*                                1027/avahi-daemon:  
udp6       0      0 :::35465                :::*                                1027/avahi-daemon:  
root@louis-PC:~# apt-get update && apt-get install odoo
获取:1 http://security.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB]   
忽略:2 http://nightly.odoo.com/13.0/nightly/deb ./ InRelease                   
命中:3 http://cn.archive.ubuntu.com/ubuntu bionic InRelease                  
命中:4 http://nightly.odoo.com/13.0/nightly/deb ./ Release
获取:6 http://cn.archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]  
获取:7 http://cn.archive.ubuntu.com/ubuntu bionic-backports InRelease [74.6 kB]
获取:8 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 DEP-11 Metadata [295 kB]
获取:9 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 48x48 Icons [73.8 kB]
获取:10 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 64x64 Icons [143 kB]
获取:11 http://cn.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 DEP-11 Metadata [254 kB]
错误:1 http://security.ubuntu.com/ubuntu bionic-security InRelease             
  连接超时 [IP: 91.189.91.14 80]
获取:12 http://cn.archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 48x48 Icons [193 kB]
获取:13 http://cn.archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 64x64 Icons [439 kB]
获取:14 http://cn.archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64 DEP-11 Metadata [2,464 B]
获取:15 http://cn.archive.ubuntu.com/ubuntu bionic-backports/universe amd64 Packages [4,024 B]
获取:16 http://cn.archive.ubuntu.com/ubuntu bionic-backports/universe i386 Packages [4,028 B]
获取:17 http://cn.archive.ubuntu.com/ubuntu bionic-backports/universe amd64 DEP-11 Metadata [7,920 B]
已下载 1,579 kB,耗时 60秒 (26.3 kB/s)                                         
正在读取软件包列表... 完成
W: 无法下载 http://security.ubuntu.com/ubuntu/dists/bionic-security/InRelease  连接超时 [IP: 91.189.91.14 80]
W: 部分索引文件下载失败。如果忽略它们,那将转而使用旧的索引文件。
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
下列软件包是自动安装的并且现在不需要了:
  binutils-common:i386 binutils-i686-linux-gnu gcc-7-base:i386 libasan4:i386
  libbinutils:i386 libcc1-0:i386 libcilkrts5:i386 libgcc-7-dev:i386
  libgomp1:i386 libisl19:i386 libitm1:i386 libllvm7 libmpc3:i386 libmpfr6:i386
  libmpx2:i386 libquadmath0:i386 libubsan0:i386
使用'apt autoremove'来卸载它(它们)。
将会同时安装下列软件:
  docutils-common graphviz javascript-common libann0 libcdt5 libcgraph6
  libgts-0.7-5 libgts-bin libgvc6 libgvpr2 libjs-jquery liblab-gamut1
  libpathplan4 libsass0 python-babel-localedata python-ldap python-pyasn1
  python-pyasn1-modules python3-aiohttp python3-appdirs python3-async-timeout
  python3-attr python3-babel python3-bs4 python3-cached-property
  python3-decorator python3-defusedxml python3-docutils python3-feedparser
  python3-freezegun python3-gevent python3-greenlet python3-html2text
  python3-html5lib python3-isodate python3-jinja2 python3-ldap python3-libsass
  python3-lxml python3-mock python3-multidict python3-ofxparse python3-openssl
  python3-passlib python3-pbr python3-polib python3-psutil python3-psycopg2
  python3-pyasn1 python3-pyasn1-modules python3-pydot python3-pygments
  python3-pyinotify python3-pyldap python3-pyparsing python3-pypdf2
  python3-qrcode python3-requests-toolbelt python3-roman python3-serial
  python3-stdnum python3-suds python3-usb python3-vatnumber python3-vobject
  python3-webencodings python3-werkzeug python3-xlrd python3-xlsxwriter
  python3-yarl python3-zeep sgml-base xml-core
建议安装:
  graphviz-doc apache2 | lighttpd | httpd python-attr-doc docutils-doc
  fonts-linuxlibertine | ttf-linux-libertine texlive-lang-french
  texlive-latex-base texlive-latex-recommended python-gevent-doc
  python3-gevent-dbg python-greenlet-doc python-greenlet-dev
  python3-greenlet-dbg python3-genshi python-jinja2-doc python3-lxml-dbg
  python-lxml-doc python-mock-doc python-openssl-doc python3-openssl-dbg
  python-polib-doc python-psutil-doc python-psycopg2-doc ttf-bitstream-vera
  python-pyinotify-doc python-pyparsing-doc python3-wxgtk3.0 | python3-wxgtk
  python-stdnum-doc ipython3 python3-termcolor python3-watchdog
  python-werkzeug-doc sgml-base-doc debhelper
下列【新】软件包将被安装:
  docutils-common graphviz javascript-common libann0 libcdt5 libcgraph6
  libgts-0.7-5 libgts-bin libgvc6 libgvpr2 libjs-jquery liblab-gamut1
  libpathplan4 libsass0 odoo python-babel-localedata python-ldap python-pyasn1
  python-pyasn1-modules python3-aiohttp python3-appdirs python3-async-timeout
  python3-attr python3-babel python3-bs4 python3-cached-property
  python3-decorator python3-defusedxml python3-docutils python3-feedparser
  python3-freezegun python3-gevent python3-greenlet python3-html2text
  python3-html5lib python3-isodate python3-jinja2 python3-ldap python3-libsass
  python3-lxml python3-mock python3-multidict python3-ofxparse python3-openssl
  python3-passlib python3-pbr python3-polib python3-psutil python3-psycopg2
  python3-pyasn1 python3-pyasn1-modules python3-pydot python3-pygments
  python3-pyinotify python3-pyldap python3-pyparsing python3-pypdf2
  python3-qrcode python3-requests-toolbelt python3-roman python3-serial
  python3-stdnum python3-suds python3-usb python3-vatnumber python3-vobject
  python3-webencodings python3-werkzeug python3-xlrd python3-xlsxwriter
  python3-yarl python3-zeep sgml-base xml-core
升级了 0 个软件包,新安装了 74 个软件包,要卸载 0 个软件包,有 3 个软件包未被升级。
需要下载 371 kB/69.4 MB 的归档。
解压缩后会消耗 571 MB 的额外空间。
您希望继续执行吗? [Y/n] y
获取:1 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 python3-gevent amd64 1.2.2-2 [371 kB]
已下载 4,278 B,耗时 11秒 (385 B/s)                                            
正在从软件包中解出模板:100%
正在选中未选择的软件包 libsass0:amd64。
(正在读取数据库 ... 系统当前共安装有 181244 个文件和目录。)
正准备解包 .../00-libsass0_3.4.8-1_amd64.deb  ...
正在解包 libsass0:amd64 (3.4.8-1) ...
正在选中未选择的软件包 sgml-base。
正准备解包 .../01-sgml-base_1.29_all.deb  ...
正在解包 sgml-base (1.29) ...
正在选中未选择的软件包 xml-core。
正准备解包 .../02-xml-core_0.18_all.deb  ...
正在解包 xml-core (0.18) ...
正在选中未选择的软件包 docutils-common。
正准备解包 .../03-docutils-common_0.14+dfsg-3_all.deb  ...
正在解包 docutils-common (0.14+dfsg-3) ...
正在选中未选择的软件包 libann0。
正准备解包 .../04-libann0_1.1.2+doc-6_amd64.deb  ...
正在解包 libann0 (1.1.2+doc-6) ...
正在选中未选择的软件包 libcdt5。
正准备解包 .../05-libcdt5_2.40.1-2_amd64.deb  ...
正在解包 libcdt5 (2.40.1-2) ...
正在选中未选择的软件包 libcgraph6。
正准备解包 .../06-libcgraph6_2.40.1-2_amd64.deb  ...
正在解包 libcgraph6 (2.40.1-2) ...
正在选中未选择的软件包 libgts-0.7-5:amd64。
正准备解包 .../07-libgts-0.7-5_0.7.6+darcs121130-4_amd64.deb  ...
正在解包 libgts-0.7-5:amd64 (0.7.6+darcs121130-4) ...
正在选中未选择的软件包 libpathplan4。
正准备解包 .../08-libpathplan4_2.40.1-2_amd64.deb  ...
正在解包 libpathplan4 (2.40.1-2) ...
正在选中未选择的软件包 libgvc6。
正准备解包 .../09-libgvc6_2.40.1-2_amd64.deb  ...
正在解包 libgvc6 (2.40.1-2) ...
正在选中未选择的软件包 libgvpr2。
正准备解包 .../10-libgvpr2_2.40.1-2_amd64.deb  ...
正在解包 libgvpr2 (2.40.1-2) ...
正在选中未选择的软件包 liblab-gamut1。
正准备解包 .../11-liblab-gamut1_2.40.1-2_amd64.deb  ...
正在解包 liblab-gamut1 (2.40.1-2) ...
正在选中未选择的软件包 graphviz。
正准备解包 .../12-graphviz_2.40.1-2_amd64.deb  ...
正在解包 graphviz (2.40.1-2) ...
正在选中未选择的软件包 javascript-common。
正准备解包 .../13-javascript-common_11_all.deb  ...
正在解包 javascript-common (11) ...
正在选中未选择的软件包 libgts-bin。
正准备解包 .../14-libgts-bin_0.7.6+darcs121130-4_amd64.deb  ...
正在解包 libgts-bin (0.7.6+darcs121130-4) ...
正在选中未选择的软件包 libjs-jquery。
正准备解包 .../15-libjs-jquery_3.2.1-1_all.deb  ...
正在解包 libjs-jquery (3.2.1-1) ...
正在选中未选择的软件包 python-babel-localedata。
正准备解包 .../16-python-babel-localedata_2.4.0+dfsg.1-2ubuntu1_all.deb  ...
正在解包 python-babel-localedata (2.4.0+dfsg.1-2ubuntu1) ...
正在选中未选择的软件包 python3-babel。
正准备解包 .../17-python3-babel_2.4.0+dfsg.1-2ubuntu1_all.deb  ...
正在解包 python3-babel (2.4.0+dfsg.1-2ubuntu1) ...
正在选中未选择的软件包 python3-decorator。
正准备解包 .../18-python3-decorator_4.1.2-1_all.deb  ...
正在解包 python3-decorator (4.1.2-1) ...
正在选中未选择的软件包 python3-roman。
正准备解包 .../19-python3-roman_2.0.0-3_all.deb  ...
正在解包 python3-roman (2.0.0-3) ...
正在选中未选择的软件包 python3-docutils。
正准备解包 .../20-python3-docutils_0.14+dfsg-3_all.deb  ...
正在解包 python3-docutils (0.14+dfsg-3) ...
正在选中未选择的软件包 python3-feedparser。
正准备解包 .../21-python3-feedparser_5.2.1-1_all.deb  ...
正在解包 python3-feedparser (5.2.1-1) ...
正在选中未选择的软件包 python3-greenlet。
正准备解包 .../22-python3-greenlet_0.4.12-2_amd64.deb  ...
正在解包 python3-greenlet (0.4.12-2) ...
正在选中未选择的软件包 python3-gevent。
正准备解包 .../23-python3-gevent_1.2.2-2_amd64.deb  ...
正在解包 python3-gevent (1.2.2-2) ...
正在选中未选择的软件包 python3-html2text。
正准备解包 .../24-python3-html2text_2018.1.9-1_all.deb  ...
正在解包 python3-html2text (2018.1.9-1) ...
正在选中未选择的软件包 python3-jinja2。
正准备解包 .../25-python3-jinja2_2.10-1ubuntu0.18.04.1_all.deb  ...
正在解包 python3-jinja2 (2.10-1ubuntu0.18.04.1) ...
正在选中未选择的软件包 python3-libsass。
正准备解包 .../26-python3-libsass_0.12.3-2ubuntu4_amd64.deb  ...
正在解包 python3-libsass (0.12.3-2ubuntu4) ...
正在选中未选择的软件包 python3-lxml:amd64。
正准备解包 .../27-python3-lxml_4.2.1-1ubuntu0.1_amd64.deb  ...
正在解包 python3-lxml:amd64 (4.2.1-1ubuntu0.1) ...
正在选中未选择的软件包 python3-pbr。
正准备解包 .../28-python3-pbr_3.1.1-3ubuntu3_all.deb  ...
正在解包 python3-pbr (3.1.1-3ubuntu3) ...
正在选中未选择的软件包 python3-mock。
正准备解包 .../29-python3-mock_2.0.0-3_all.deb  ...
正在解包 python3-mock (2.0.0-3) ...
正在选中未选择的软件包 python3-bs4。
正准备解包 .../30-python3-bs4_4.6.0-1_all.deb  ...
正在解包 python3-bs4 (4.6.0-1) ...
正在选中未选择的软件包 python3-ofxparse。
正准备解包 .../31-python3-ofxparse_0.15+git20161013-1_all.deb  ...
正在解包 python3-ofxparse (0.15+git20161013-1) ...
正在选中未选择的软件包 python3-passlib。
正准备解包 .../32-python3-passlib_1.7.1-1_all.deb  ...
正在解包 python3-passlib (1.7.1-1) ...
正在选中未选择的软件包 python3-polib。
正准备解包 .../33-python3-polib_1.1.0-3_all.deb  ...
正在解包 python3-polib (1.1.0-3) ...
正在选中未选择的软件包 python3-psutil。
正准备解包 .../34-python3-psutil_5.4.2-1_amd64.deb  ...
正在解包 python3-psutil (5.4.2-1) ...
正在选中未选择的软件包 python3-psycopg2。
正准备解包 .../35-python3-psycopg2_2.7.4-1_amd64.deb  ...
正在解包 python3-psycopg2 (2.7.4-1) ...
正在选中未选择的软件包 python3-pyparsing。
正准备解包 .../36-python3-pyparsing_2.2.0+dfsg1-2_all.deb  ...
正在解包 python3-pyparsing (2.2.0+dfsg1-2) ...
正在选中未选择的软件包 python3-pydot。
正准备解包 .../37-python3-pydot_1.2.3-1_all.deb  ...
正在解包 python3-pydot (1.2.3-1) ...
正在选中未选择的软件包 python3-pypdf2。
正准备解包 .../38-python3-pypdf2_1.26.0-2_all.deb  ...
正在解包 python3-pypdf2 (1.26.0-2) ...
正在选中未选择的软件包 python3-qrcode。
正准备解包 .../39-python3-qrcode_5.3-1_all.deb  ...
正在解包 python3-qrcode (5.3-1) ...
正在选中未选择的软件包 python3-serial。
正准备解包 .../40-python3-serial_3.4-2_all.deb  ...
正在解包 python3-serial (3.4-2) ...
正在选中未选择的软件包 python3-usb。
正准备解包 .../41-python3-usb_1.0.0-1_all.deb  ...
正在解包 python3-usb (1.0.0-1) ...
正在选中未选择的软件包 python3-stdnum。
正准备解包 .../42-python3-stdnum_1.8.1-1_all.deb  ...
正在解包 python3-stdnum (1.8.1-1) ...
正在选中未选择的软件包 python3-vatnumber。
正准备解包 .../43-python3-vatnumber_1%3a1.2-7_all.deb  ...
正在解包 python3-vatnumber (1:1.2-7) ...
正在选中未选择的软件包 python3-vobject。
正准备解包 .../44-python3-vobject_0.9.5-1_all.deb  ...
正在解包 python3-vobject (0.9.5-1) ...
正在选中未选择的软件包 python3-werkzeug。
正准备解包 .../45-python3-werkzeug_0.14.1+dfsg1-1_all.deb  ...
正在解包 python3-werkzeug (0.14.1+dfsg1-1) ...
正在选中未选择的软件包 python3-xlsxwriter。
正准备解包 .../46-python3-xlsxwriter_0.9.6-0.1_all.deb  ...
正在解包 python3-xlsxwriter (0.9.6-0.1) ...
正在选中未选择的软件包 python3-async-timeout。
正准备解包 .../47-python3-async-timeout_2.0.0-1_all.deb  ...
正在解包 python3-async-timeout (2.0.0-1) ...
正在选中未选择的软件包 python3-attr。
正准备解包 .../48-python3-attr_17.4.0-2_all.deb  ...
正在解包 python3-attr (17.4.0-2) ...
正在选中未选择的软件包 python3-multidict。
正准备解包 .../49-python3-multidict_4.1.0-1_amd64.deb  ...
正在解包 python3-multidict (4.1.0-1) ...
正在选中未选择的软件包 python3-yarl。
正准备解包 .../50-python3-yarl_1.1.0-1_amd64.deb  ...
正在解包 python3-yarl (1.1.0-1) ...
正在选中未选择的软件包 python3-aiohttp。
正准备解包 .../51-python3-aiohttp_3.0.1-1_amd64.deb  ...
正在解包 python3-aiohttp (3.0.1-1) ...
正在选中未选择的软件包 python3-appdirs。
正准备解包 .../52-python3-appdirs_1.4.3-1_all.deb  ...
正在解包 python3-appdirs (1.4.3-1) ...
正在选中未选择的软件包 python3-cached-property。
正准备解包 .../53-python3-cached-property_1.3.1-1_all.deb  ...
正在解包 python3-cached-property (1.3.1-1) ...
正在选中未选择的软件包 python3-defusedxml。
正准备解包 .../54-python3-defusedxml_0.5.0-1ubuntu1_all.deb  ...
正在解包 python3-defusedxml (0.5.0-1ubuntu1) ...
正在选中未选择的软件包 python3-freezegun。
正准备解包 .../55-python3-freezegun_0.3.9-1_all.deb  ...
正在解包 python3-freezegun (0.3.9-1) ...
正在选中未选择的软件包 python3-isodate。
正准备解包 .../56-python3-isodate_0.6.0-1_all.deb  ...
正在解包 python3-isodate (0.6.0-1) ...
正在选中未选择的软件包 python3-requests-toolbelt。
正准备解包 .../57-python3-requests-toolbelt_0.8.0-1_all.deb  ...
正在解包 python3-requests-toolbelt (0.8.0-1) ...
正在选中未选择的软件包 python3-zeep。
正准备解包 .../58-python3-zeep_2.5.0-1_all.deb  ...
正在解包 python3-zeep (2.5.0-1) ...
正在选中未选择的软件包 python3-suds。
正准备解包 .../59-python3-suds_0.7~git20150727.94664dd-5_all.deb  ...
正在解包 python3-suds (0.7~git20150727.94664dd-5) ...
正在选中未选择的软件包 python3-xlrd。
正准备解包 .../60-python3-xlrd_1.1.0-1_all.deb  ...
正在解包 python3-xlrd (1.1.0-1) ...
正在选中未选择的软件包 odoo。
正准备解包 .../61-odoo_13.0.20191031_all.deb  ...
正在解包 odoo (13.0.20191031) ...
正在选中未选择的软件包 python-pyasn1。
正准备解包 .../62-python-pyasn1_0.4.2-3_all.deb  ...
正在解包 python-pyasn1 (0.4.2-3) ...
正在选中未选择的软件包 python-pyasn1-modules。
正准备解包 .../63-python-pyasn1-modules_0.2.1-0.2_all.deb  ...
正在解包 python-pyasn1-modules (0.2.1-0.2) ...
正在选中未选择的软件包 python-ldap。
正准备解包 .../64-python-ldap_3.0.0-1_amd64.deb  ...
正在解包 python-ldap (3.0.0-1) ...
正在选中未选择的软件包 python3-webencodings。
正准备解包 .../65-python3-webencodings_0.5-2_all.deb  ...
正在解包 python3-webencodings (0.5-2) ...
正在选中未选择的软件包 python3-html5lib。
正准备解包 .../66-python3-html5lib_0.999999999-1_all.deb  ...
正在解包 python3-html5lib (0.999999999-1) ...
正在选中未选择的软件包 python3-pyasn1。
正准备解包 .../67-python3-pyasn1_0.4.2-3_all.deb  ...
正在解包 python3-pyasn1 (0.4.2-3) ...
正在选中未选择的软件包 python3-pyasn1-modules。
正准备解包 .../68-python3-pyasn1-modules_0.2.1-0.2_all.deb  ...
正在解包 python3-pyasn1-modules (0.2.1-0.2) ...
正在选中未选择的软件包 python3-ldap。
正准备解包 .../69-python3-ldap_3.0.0-1_amd64.deb  ...
正在解包 python3-ldap (3.0.0-1) ...
正在选中未选择的软件包 python3-openssl。
正准备解包 .../70-python3-openssl_17.5.0-1ubuntu1_all.deb  ...
正在解包 python3-openssl (17.5.0-1ubuntu1) ...
正在选中未选择的软件包 python3-pygments。
正准备解包 .../71-python3-pygments_2.2.0+dfsg-1_all.deb  ...
正在解包 python3-pygments (2.2.0+dfsg-1) ...
正在选中未选择的软件包 python3-pyinotify。
正准备解包 .../72-python3-pyinotify_0.9.6-1_all.deb  ...
正在解包 python3-pyinotify (0.9.6-1) ...
正在选中未选择的软件包 python3-pyldap。
正准备解包 .../73-python3-pyldap_3.0.0-1_amd64.deb  ...
正在解包 python3-pyldap (3.0.0-1) ...
正在设置 python3-requests-toolbelt (0.8.0-1) ...
正在设置 libjs-jquery (3.2.1-1) ...
正在设置 python3-werkzeug (0.14.1+dfsg1-1) ...
正在设置 libgts-0.7-5:amd64 (0.7.6+darcs121130-4) ...
正在设置 python3-html2text (2018.1.9-1) ...
update-alternatives: 使用 /usr/bin/html2markdown.py3 来在自动模式中提供 /usr/bin/html2markdown (html2markdown)
正在设置 python3-pypdf2 (1.26.0-2) ...
正在设置 python3-pbr (3.1.1-3ubuntu3) ...
update-alternatives: 使用 /usr/bin/python3-pbr 来在自动模式中提供 /usr/bin/pbr (pbr)
正在设置 libpathplan4 (2.40.1-2) ...
正在设置 python3-usb (1.0.0-1) ...
正在设置 python3-xlsxwriter (0.9.6-0.1) ...
正在设置 python3-passlib (1.7.1-1) ...
正在设置 python3-roman (2.0.0-3) ...
正在设置 liblab-gamut1 (2.40.1-2) ...
正在设置 python3-webencodings (0.5-2) ...
正在设置 python3-greenlet (0.4.12-2) ...
正在设置 python3-serial (3.4-2) ...
正在设置 python3-async-timeout (2.0.0-1) ...
正在设置 python3-lxml:amd64 (4.2.1-1ubuntu0.1) ...
正在设置 python3-mock (2.0.0-3) ...
正在设置 python-pyasn1 (0.4.2-3) ...
正在设置 python3-pyparsing (2.2.0+dfsg1-2) ...
正在设置 python3-appdirs (1.4.3-1) ...
正在设置 python3-multidict (4.1.0-1) ...
正在设置 sgml-base (1.29) ...
正在设置 python3-bs4 (4.6.0-1) ...
正在设置 python-pyasn1-modules (0.2.1-0.2) ...
正在设置 python3-psutil (5.4.2-1) ...
正在设置 python3-suds (0.7~git20150727.94664dd-5) ...
正在设置 python3-feedparser (5.2.1-1) ...
正在设置 python3-cached-property (1.3.1-1) ...
正在设置 python3-psycopg2 (2.7.4-1) ...
正在设置 python3-pyasn1 (0.4.2-3) ...
正在设置 python3-defusedxml (0.5.0-1ubuntu1) ...
正在设置 python3-polib (1.1.0-3) ...
正在设置 python3-jinja2 (2.10-1ubuntu0.18.04.1) ...
正在设置 python3-html5lib (0.999999999-1) ...
正在设置 python-babel-localedata (2.4.0+dfsg.1-2ubuntu1) ...
正在设置 python3-xlrd (1.1.0-1) ...
正在设置 python3-stdnum (1.8.1-1) ...
正在设置 libann0 (1.1.2+doc-6) ...
正在设置 python3-pyasn1-modules (0.2.1-0.2) ...
正在设置 python3-attr (17.4.0-2) ...
正在设置 python3-openssl (17.5.0-1ubuntu1) ...
正在设置 python3-qrcode (5.3-1) ...
update-alternatives: 使用 /usr/bin/python3-qr 来在自动模式中提供 /usr/bin/qr (qr)
正在设置 libgts-bin (0.7.6+darcs121130-4) ...
正在设置 xml-core (0.18) ...
正在设置 javascript-common (11) ...
正在设置 python3-vobject (0.9.5-1) ...
正在设置 python3-decorator (4.1.2-1) ...
正在设置 python3-ofxparse (0.15+git20161013-1) ...
正在设置 libcdt5 (2.40.1-2) ...
正在设置 python3-pyinotify (0.9.6-1) ...
正在设置 libcgraph6 (2.40.1-2) ...
正在设置 python3-freezegun (0.3.9-1) ...
正在设置 python-ldap (3.0.0-1) ...
正在设置 python3-isodate (0.6.0-1) ...
正在设置 python3-gevent (1.2.2-2) ...
正在设置 libsass0:amd64 (3.4.8-1) ...
正在设置 python3-pygments (2.2.0+dfsg-1) ...
正在设置 python3-ldap (3.0.0-1) ...
正在设置 libgvc6 (2.40.1-2) ...
正在设置 libgvpr2 (2.40.1-2) ...
正在设置 python3-vatnumber (1:1.2-7) ...
正在设置 python3-yarl (1.1.0-1) ...
正在设置 python3-pyldap (3.0.0-1) ...
正在设置 python3-babel (2.4.0+dfsg.1-2ubuntu1) ...
update-alternatives: 使用 /usr/bin/pybabel-python3 来在自动模式中提供 /usr/bin/pybabel (pybabel)
正在设置 python3-aiohttp (3.0.1-1) ...
正在设置 python3-libsass (0.12.3-2ubuntu4) ...
正在设置 graphviz (2.40.1-2) ...
正在设置 python3-pydot (1.2.3-1) ...
正在设置 python3-zeep (2.5.0-1) ...
正在处理用于 libc-bin (2.27-3ubuntu1) 的触发器 ...
正在处理用于 systemd (237-3ubuntu10.31) 的触发器 ...
正在处理用于 man-db (2.8.3-2ubuntu0.1) 的触发器 ...
正在处理用于 shared-mime-info (1.9-2) 的触发器 ...
正在处理用于 ureadahead (0.100.0-21) 的触发器 ...
正在处理用于 sgml-base (1.29) 的触发器 ...
正在设置 docutils-common (0.14+dfsg-3) ...
正在处理用于 sgml-base (1.29) 的触发器 ...
正在设置 python3-docutils (0.14+dfsg-3) ...
update-alternatives: 使用 /usr/share/docutils/scripts/python3/rst-buildhtml 来在自动模式中提供 /usr/bin/rst-buildhtml (rst-buildhtml)
update-alternatives: 使用 /usr/share/docutils/scripts/python3/rst2html 来在自动模式中提供 /usr/bin/rst2html (rst2html)
update-alternatives: 使用 /usr/share/docutils/scripts/python3/rst2html4 来在自动模式中提供 /usr/bin/rst2html4 (rst2html4)
update-alternatives: 使用 /usr/share/docutils/scripts/python3/rst2html5 来在自动模式中提供 /usr/bin/rst2html5 (rst2html5)
update-alternatives: 使用 /usr/share/docutils/scripts/python3/rst2latex 来在自动模式中提供 /usr/bin/rst2latex (rst2latex)
update-alternatives: 使用 /usr/share/docutils/scripts/python3/rst2man 来在自动模式中提供 /usr/bin/rst2man (rst2man)
update-alternatives: 使用 /usr/share/docutils/scripts/python3/rst2odt 来在自动模式中提供 /usr/bin/rst2odt (rst2odt)
update-alternatives: 使用 /usr/share/docutils/scripts/python3/rst2odt_prepstyles 来在自动模式中提供 /usr/bin/rst2odt_prepstyles (rst2odt_prepstyles)
update-alternatives: 使用 /usr/share/docutils/scripts/python3/rst2pseudoxml 来在自动模式中提供 /usr/bin/rst2pseudoxml (rst2pseudoxml)
update-alternatives: 使用 /usr/share/docutils/scripts/python3/rst2s5 来在自动模式中提供 /usr/bin/rst2s5 (rst2s5)
update-alternatives: 使用 /usr/share/docutils/scripts/python3/rst2xetex 来在自动模式中提供 /usr/bin/rst2xetex (rst2xetex)
update-alternatives: 使用 /usr/share/docutils/scripts/python3/rst2xml 来在自动模式中提供 /usr/bin/rst2xml (rst2xml)
update-alternatives: 使用 /usr/share/docutils/scripts/python3/rstpep2html 来在自动模式中提供 /usr/bin/rstpep2html (rstpep2html)
正在设置 odoo (13.0.20191031) ...
Created symlink /etc/systemd/system/multi-user.target.wants/odoo.service → /lib/systemd/system/odoo.service.
正在处理用于 systemd (237-3ubuntu10.31) 的触发器 ...
正在处理用于 ureadahead (0.100.0-21) 的触发器 ...
root@louis-PC:~# netstat -plntu
激活Internet连接 (仅服务器)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name    
tcp        0      0 127.0.0.53:53           0.0.0.0:*               LISTEN      8068/systemd-resolv 
tcp        0      0 127.0.0.1:631           0.0.0.0:*               LISTEN      2779/cupsd          
tcp        0      0 127.0.0.1:5432          0.0.0.0:*               LISTEN      4375/postgres       
tcp        0      0 0.0.0.0:8069            0.0.0.0:*               LISTEN      22306/python3       
tcp6       0      0 ::1:631                 :::*                    LISTEN      2779/cupsd          
udp        0      0 127.0.0.53:53           0.0.0.0:*                           8068/systemd-resolv 
udp        0      0 0.0.0.0:68              0.0.0.0:*                           2433/dhclient       
udp        0      0 0.0.0.0:53400           0.0.0.0:*                           1027/avahi-daemon:  
udp        0      0 0.0.0.0:631             0.0.0.0:*                           2780/cups-browsed   
udp        0      0 0.0.0.0:5353            0.0.0.0:*                           1027/avahi-daemon:  
udp6       0      0 :::5353                 :::*                                1027/avahi-daemon:  
udp6       0      0 :::35465                :::*                                1027/avahi-daemon:  
root@louis-PC:~# 

发表评论

您的电子邮箱地址不会被公开。